POJ1753--Flip Game(枚举)

26 篇文章 0 订阅

Do more with less

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it’s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
这里写图片描述
bwbw
wwww
bbwb
bwwb
Here “b” denotes pieces lying their black side up and “w” denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters “w” or “b” each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it’s impossible to achieve the goal, then write the word “Impossible” (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

思路

只有正反两面,可以用0,1表示,就可以把一行的状态压缩到一个char型变量里面
当确定了第一行的状态之后,第二行的状态有第一行确定
枚举第一行的状态的所有情况
最后一行符合要求的时候,记录一个翻的次数
比较得到最小次数
有两种状态符合要求,全黑和全白

代码

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
char piece[4][4];
char oripiece[4];
char pieces[4];
char result[4];
int ans = 0;
int mintime = 1 << 30;
void SetBit(char &c,int i,char v)
{
    int m = 0;
    if(v == 'w')
        m = 1;
    if(m)
        c |= (1 << i);
    else
        c &= ~(1 << i);
}
int GetBit(char c, int i)
{
    return (c >> i) & 1;
}
void FlipBit(char &c,int i)
{
    c ^= (1 << i);
}
using namespace std;

int main()
{
    int x = 0;
    int y = 0;
    for(int i = 0; i < 4; i ++)
        for(int j = 0; j < 4; j ++)
        {
            cin >> piece[i][j];
            SetBit(oripiece[i],j,piece[i][j]);
            if(piece[i][j] == 'b') x ++;
            else if(piece[i][j] == 'w') y ++;
        }
    if(x == 16 || y == 16)
    {
        cout << "0" << endl;
        return 0;
    }
    for(int k = 0; k < 16; k ++)
    {
        ans = 0;
        int switchs = k;
        memcpy(pieces,oripiece,sizeof(oripiece));
        for(int i = 0; i < 4; i ++)
        {
            result[i] = switchs;
            for(int j = 0;j < 4; j ++)
            {
                if(GetBit(result[i],j))
                {
                    ans ++;
                    FlipBit(pieces[i],j);
                    if(j > 0)
                        FlipBit(pieces[i],j-1);
                    if(j < 3)
                        FlipBit(pieces[i],j+1);
                    if(i < 3)
                        FlipBit(pieces[i+1],j);
                }
            }
            switchs = pieces[i];
        }
        if(pieces[3] == 0)
            mintime = min(mintime,ans);
    }
    for(int k = 0; k < 16; k ++)
    {
        ans = 0;
        int switchs = k;
        memcpy(pieces,oripiece,sizeof(oripiece));
        for(int i = 0; i < 4; i ++)
        {
            result[i] = switchs;
            for(int j = 0;j < 4; j ++)
            {
                if(GetBit(result[i],j))
                {
                    ans ++;
                    FlipBit(pieces[i],j);
                    if(j > 0)
                        FlipBit(pieces[i],j-1);
                    if(j < 3)
                        FlipBit(pieces[i],j+1);
                    if(i < 3)
                        FlipBit(pieces[i+1],j);
                }
            }
            switchs = ~pieces[i];
        }
        if(pieces[3] == 15)
            mintime = min(mintime,ans);
    }
    if(mintime != 1 << 30)
        cout << mintime << endl;
    else
        cout << "Impossible" << endl;
    return 0;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值