2017 ACM/ICPC Asia Regional Shenyang Online 1004 array array array

Problem Description

One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo’s path to escape from the museum. But Kiddo didn’t want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: “I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. ” Conan: “emmmmm…” Now, Conan seems to be in trouble, can you help him?

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2…An.
1≤T≤20
1≤n≤105
0≤k≤n
1≤Ai≤105

Output

For each test case, please output “A is a magic array.” if it is a magic array. Otherwise, output “A is not a magic array.” (without quotes).

Sample Input

3
4 1
1 4 3 7
5 2
4 1 3 1 2
6 1
1 4 3 5 4 6

Sample Output

A is a magic array.
A is a magic array.
A is not a magic array.

题意

去掉m个数,长度为n的序列是否可以成为上升或下降序列

思路

最长上升(下降)子序列暴力一下

代码

这里写代码片#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=100005;
int a[N],b[N],c[N];
int main()
{
    int T,m,n;
    scanf("%d",&T);
    while(T--)
    {
        bool flag = true;
        scanf("%d%d",&m,&n);
        for(int i=1;i<=m;i++)
            scanf("%d",&a[i]);
        int maxb=0,maxc=0;
        b[1]=c[1]=1;
        for(int i=2;i<=m;i++)
        {
            int tmpb=0,tmpc=0;
            for(int j=1;j<=i-1;j++)
            {
                if(a[j] <= a[i])//递增序列
                    tmpb = max(b[j],tmpb);
                if(a[j] >= a[i])
                    tmpc = max(c[j],tmpc);
            }
            b[i]=tmpb+1;
            c[i]=tmpc+1;
            maxb=max(maxb,b[i]);
            maxc=max(maxc,c[i]);
            if(i - maxb > n && i - maxc > n)
            {
                flag = false;
                break;
            }
        }
        if(flag == false)
        {
            printf("A is not a magic array.\n");
            continue;
        }
        if(maxb+n>=m || maxc+n>=m)
            printf("A is a magic array.\n");
        else
            printf("A is not a magic array.\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值