Problem Description
对于包含n(1<=n<=100000)个整数的序列,对于序列中的每一元素,在序列中查找其位置之后第一个大于它的值,如果找到,输出所找到的值,否则,输出-1。
Input
输入有多组,第一行输入t(1<=t<=10),表示输入的组数;
以后是 t 组输入:每组先输入n,表示本组序列的元素个数,之后依次输入本组的n个元素。
Output
输出有多组,每组之间输出一个空行(最后一组之后没有);
每组输出按照本序列元素的顺序,依次逐行输出当前元素及其查找结果,两者之间以–>间隔。
Example Input
2
4 12 20 15 18
5 20 15 25 30 6
Example Output
12–>20
20–>-1
15–>18
18–>-120–>25
15–>25
25–>30
30–>-1
6–>-1
思路
看代码吧
代码
#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;
const int maxn = 100005;
typedef struct
{
int num;
int next;
int id;
}node;
node a[maxn],temp;
int n;
void getnext()
{
stack<node> s;
for(int i = 0; i < n; i ++)
{
if( s.empty() )
s.push(a[i]);
else
{
while( !s.empty() )
{
temp = s.top();
if(temp.num < a[i].num)
a[temp.id].next = a[i].num;
else break;
s.pop();
}
}
s.push(a[i]);
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i = 0; i < n; i ++)
{
scanf("%d",&a[i].num);
a[i].next = -1;
a[i].id = i;
}
getnext();
for(int i = 0; i < n; i ++)
printf("%d-->%d\n",a[i].num,a[i].next);
if(t > 0)
printf("\n");
}
}