HDU 1319 Prime Cuts(素数。。。)

Prime Cuts

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1668    Accepted Submission(s): 705


Problem Description
A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.
 

Input
Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.
 

Output
For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.
 

Sample Input
  
  
21 2 18 2 18 18 100 7
 

Sample Output
  
  
21 2: 5 7 11 18 2: 3 5 7 11 18 18: 1 2 3 5 7 11 13 17 100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67
 

Source
 

Recommend
Eddy
 
这个题目虽然是个水题。。。但是 在输出方面需要注意 (本题1也是素数),当1~N之间的素数个数为偶数时,取到中间后输出C*2个(1~N之间的素数),为奇数输出C*2-1个(1~N之间的素数)。。。在输出时,,只要控制两端的下标即可轻易求输出范围。。。在这里先加右边的下标,,同时判断K的个数为0时结束。。。再加上左边的下标。。因为我的数组从0存储的。。则反之。。。俺们不幸WA一次。。。。。
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	int a[1001],b[1001];
	int i,j,k,count;
	int n,c;
    memset(a,0,sizeof(a));
	a[0]=1;a[1]=0;
	for(i=2;i<1001;i++)
	{
		if(!a[i])
		{
           for(j=i+i;j<1001;j+=i)
			   a[j]=1;
		}
	}
	 
	while(cin>>n>>c)
	{
       for(i=1,count=0;i<=n;i++)
	   {
		   if(!a[i])
			  b[count++]=i;
	   }

	   if(count%2==0)
		   k=c*2;
	   else 
		   k=c*2-1;
		   cout<<n<<' '<<c<<':';
      if(k>=count)
	  {
		  for(j=0;j<count;j++)
	      cout<<' '<<b[j];
	  }
	  else 
	  {
         for(i=j=count/2,k-=1;k&&i&&j<=count;)
		 {   
		      if(k)
			  {
				 i--;k--;
			  }
			  else break;
			  if(k)
              {
				 j++;k--;
			  }
			  else break;
			  
		 }
		 for(;i<=j;i++)
			 cout<<' '<<b[i];
          


	  }
	   cout<<endl<<endl;
			  
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值