HDU1251 统计难题 字典树、map的使用

4 篇文章 0 订阅

统计难题

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 66447 Accepted Submission(s): 22918

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output
对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output
2
3
1
0

问题连接

问题分析

方法一,基本上是字典树模板稍微改一下就行了。每经历串的节点一次就计数+1。
方法二,用map做,map<string,int> Q,也就是一个字符串映射一个整型数,这里让整型数代表字符串出现的次数,每出现一次就计数+1。把输入的字符串一个字符一个字符地添加到临时的string对象,每得到一个前缀子串就对子串映射的数加1(如果是一开始没有添加过的串,也会添加映射,并把值初始化为0)。

代码如下

//字典树
#include<iostream>
#include<cstdio>
using namespace std;

const int maxm=1e6;
const int maxn=26;
int charmapping[256];

struct treenode{
	int count;//前缀计数
	treenode* next[maxn];
}head;

treenode memory[maxm];
int mallocp;

void init_charmapping(){
	for(int i='a';i<='z';i++) charmapping[i]=i-'a';
}

void init(){
	mallocp=0;
	head.count=0;
	for(int i=0;i<maxn;i++) head.next[i]=NULL;
}

treenode* createnew(){
	treenode* t=&memory[mallocp++];
	t->count=0;
	for(int i=0;i<maxn;i++) t->next[i]=NULL;
	return t;
}

void update(char*s){
	treenode* t=&head;
	int k,temp;
	k=0;
	while(s[k]){
		temp=charmapping[s[k]];
		if(!t->next[temp]) t->next[temp]=createnew();
		t=t->next[temp];
		t->count++;
		k++;
	}
}

int search(char*s){
	treenode* t=&head;
	int k,temp;
	k=0;
	while(s[k]){
		temp=charmapping[s[k]];
		if(!t->next[temp]) return 0;
		t=t->next[temp];
		k++;
	}
	return t->count;
}

int main(){
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	char str[15];
	init();
	init_charmapping();
	while(gets(str)&&str[0]!='\0'){
		update(str);
	}
	while(scanf("%s",str)!=EOF){
		printf("%d\n",search(str));
	}
	return 0;
}
//利用map
#include<bits/stdc++.h>
using namespace std;

int main(){
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	char str[15];
	map<string,int> count;
	while(gets(str)&&str[0]!='\0'){
		int len=strlen(str);
		string temp;
		for(int i=0;i<len;i++){
			temp+=str[i];
			count[temp]++;
		}
	}
	while(scanf("%s",str)!=EOF){
		string temp=str;
		printf("%d\n",count[temp]);
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值