HDOJ 2115 I Love This Game

题目链接:点击打开链接

题目大意:按照后面的时间排名,所用时间小的排前面,如果时间相等,按照名字的字典序排序。

此题我自己在做得第一次PE了,因为不晓得需要测试案例大于一组的时候要加一个换行

I Love This Game

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7968    Accepted Submission(s): 2732


Problem Description
Do you like playing basketball ? If you are , you may know the NBA Skills Challenge . It is the content of the basketball skills . It include several parts , such as passing , shooting , and so on. After completion of the content , the player who takes the shortest time will be the winner . Now give you their names and the time of finishing the competition , your task is to give out the rank of them ; please output their name and the rank, if they have the same time , the rank of them will be the same ,but you should output their names in lexicographic order.You may assume the names of the players are unique.

Is it a very simple problem for you? Please accept it in ten minutes.
 

Input
This problem contains multiple test cases! Ease test case contain a n(1<=n<=10) shows the number of players,then n lines will be given. Each line will contain the name of player and the time(mm:ss) of their finish.The end of the input will be indicated by an integer value of zero.
 

Output
The output format is shown as sample below.
Please output the rank of all players, the output format is shown as sample below;
Output a blank line between two cases.
 

Sample Input
  
  
10 Iverson 17:19 Bryant 07:03 Nash 09:33 Wade 07:03 Davies 11:13 Carter 14:28 Jordan 29:34 James 20:48 Parker 24:49 Kidd 26:46 0
 

Sample Output
  
  
Case #1 Bryant 1 Wade 1 Nash 3 Davies 4 Carter 5 Iverson 6 James 7 Parker 8
    
    
Kidd 9 Jordan 10
具体代码实现:

package cn.hncu.acm;
/*
 * 通过String类中的compareTo方法比较2个字符串的大小
 */
import java.util.Scanner;

public class P2115 {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int count=1;
		while(sc.hasNext()){
			int n=sc.nextInt();
			if(n==0){
				break;
			}
			if(count>1){
				//此处为PE关键点,本人就因为这里PE了一次
				System.out.println();
			}
			sc.nextLine();
			String a[]=new String[n];		//用来装名字
			String b[]=new String[n];		//用来装时间
			for(int i=0;i<n;i++){
				String str=sc.nextLine();
				String s[]=str.split(" ");
				a[i]=s[0];
				b[i]=s[1];
			}
			for(int i=0;i<n;i++){
				for(int j=i+1;j<n;j++){
					if(b[i].compareTo(b[j])>0){
						//比较时间,把名字时间的位置同时转换,得到的就是按时间顺序排列的2个数组
						String str=a[i];
						a[i]=a[j];
						a[j]=str;
						str=b[i];
						b[i]=b[j];
						b[j]=str;
					}
					if(b[i].compareTo(b[j])==0){
						if(a[i].compareTo(a[j])>0){
							//如果时间相同,则按名字的字典序排序
							String str=a[i];
							a[i]=a[j];
							a[j]=str;
							str=b[i];
							b[i]=b[j];
							b[j]=str;
						}
					}
				}
			}
			System.out.println("Case #"+count);
			count++;
			System.out.println(a[0]+" 1");		//先输出第一个
			for(int i=1;i<n;i++){
				if(b[i].equals(b[i-1])){		//如果这个时间跟上一个时间相同,则输出的序号跟上个位置序号相同
					System.out.println(a[i]+" "+i);
				}else{							//否则输出该位置的本来序号
					System.out.println(a[i]+" "+(i+1));
				}
			}
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值