HDU 5775 Bubble Sort

Bubble Sort

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 827 Accepted Submission(s): 493

Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

题意:题意:给你一个n的排列,然后对它做一遍冒泡排序,问每个数在排序中的最左边位置和最右边位置的差是多少。
思路:分析:对于一个数i,若它的右边还有比它还小的数,那么它在排序过程中还会向右移动,否则向左;当i在的位置小于i时,答案为i右边比它小的数的个数,当i的位置大于等于i时,答案为最后位置减去初始位置加上右边比它小的数,后者可以用树状数组求出。
代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
#define Max 155555
int node[Max<<2],m[Max],ans[Max],x[Max];
void build(int l,int r,int rt)
{
    node[rt]=0;
    if(l==r)
    {
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void modify(int p,int l,int r,int rt)
{
    if(l==r)
    {
        node[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)
    {
       modify(p,lson);
    }
    else
    {
       modify(p,rson);
    }
    node[rt]=node[rt<<1]+node[rt<<1|1];
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        return node[rt];
    }
    int m=(l+r)>>1;
    int sum=0;
    if(L<=m)
    {
        sum+=query(L,R,lson);
    }
   if(R>m)
    {
        sum+=query(L,R,rson);
    }
    return sum;
}
int main()
{
    int t,t1=0;
    scanf("%d",&t);
    while(t--)
    {
        int n,i;
        t1++;
        //memset(ans,0,sizeof(ans));
        scanf("%d",&n);
        build(1,n,1);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&m[i]);
            x[m[i]]=i;
        }
        for(i=n;i>=1;i--)
        {
            ans[m[i]]=query(1,m[i],1,n,1);
            modify(m[i],1,n,1);
        }
        printf("Case #%d:",t1);
        for(i=1;i<=n;i++)
        {
            if(x[i]<=i)
           printf(" %d",ans[i]);
           else
           {
               printf(" %d",ans[i]+abs(x[i]-i));
           }
        }
        printf("\n");
    }
    return 0;
}
内容概要:该题库专为研究生入学考试计算机组成原理科目设计,涵盖名校考研真题、经典教材课后习题、章节题库和模拟试题四大核心模块。名校考研真题精选多所知名高校的计算机组成原理科目及计算机联考真题,并提供详尽解析,帮助考生把握考研命题趋势与难度。经典教材课后习题包括白中英《计算机组成原理》(第5版)和唐朔飞《计算机组成原理》(第2版)的全部课后习题解答,这两部教材被众多名校列为考研指定参考书目。章节题库精选代表性考题,注重基础知识与重难点内容,帮助考生全面掌握考试大纲要求的知识点。模拟试题依据历年考研真题命题规律和热门考点,精心编制两套全真模拟试题,并附标准答案,帮助考生检验学习成果,评估应试能力。 适用人群:计划参加研究生入学考试并报考计算机组成原理科目的考生,尤其是需要系统复习和强化训练的学生。 使用场景及目标:①通过研读名校考研真题,考生可以准确把握考研命题趋势与难度,有效评估复习成效;②通过经典教材课后习题的练习,考生可以巩固基础知识,掌握解题技巧;③通过章节题库的系统练习,考生可以全面掌握考试大纲要求的各个知识点,为备考打下坚实基础;④通过模拟试题的测试,考生可以检验学习成果,评估应试能力,为正式考试做好充分准备。 其他说明:该题库不仅提供详细的题目解析,还涵盖了计算机组成原理的各个方面,包括计算机系统概述、数据表示与运算、存储器分层、指令系统、中央处理器、总线系统和输入输出系统等。考生在使用过程中应结合理论学习与实践操作,注重理解与应用,以提高应试能力和专业知识水平。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值