HDU 5775 Bubble Sort

Bubble Sort

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 827 Accepted Submission(s): 493

Problem Description
P is a permutation of the integers from 1 to N(index starting from 1).
Here is the code of Bubble Sort in C++.

for(int i=1;i<=N;++i)
for(int j=N,t;j>i;—j)
if(P[j-1] > P[j])
t=P[j],P[j]=P[j-1],P[j-1]=t;

After the sort, the array is in increasing order. ?? wants to know the absolute values of difference of rightmost place and leftmost place for every number it reached.

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each consists of one line with one integer N, followed by another line with a permutation of the integers from 1 to N, inclusive.

limits
T <= 20
1 <= N <= 100000
N is larger than 10000 in only one case.

Output
For each test case output “Case #x: y1 y2 … yN” (without quotes), where x is the test case number (starting from 1), and yi is the difference of rightmost place and leftmost place of number i.

Sample Input
2
3
3 1 2
3
1 2 3

Sample Output
Case #1: 1 1 2
Case #2: 0 0 0

Hint
In first case, (3, 1, 2) -> (3, 1, 2) -> (1, 3, 2) -> (1, 2, 3)
the leftmost place and rightmost place of 1 is 1 and 2, 2 is 2 and 3, 3 is 1 and 3
In second case, the array has already in increasing order. So the answer of every number is 0.

题意:题意:给你一个n的排列,然后对它做一遍冒泡排序,问每个数在排序中的最左边位置和最右边位置的差是多少。
思路:分析:对于一个数i,若它的右边还有比它还小的数,那么它在排序过程中还会向右移动,否则向左;当i在的位置小于i时,答案为i右边比它小的数的个数,当i的位置大于等于i时,答案为最后位置减去初始位置加上右边比它小的数,后者可以用树状数组求出。
代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
#define Max 155555
int node[Max<<2],m[Max],ans[Max],x[Max];
void build(int l,int r,int rt)
{
    node[rt]=0;
    if(l==r)
    {
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void modify(int p,int l,int r,int rt)
{
    if(l==r)
    {
        node[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    if(p<=m)
    {
       modify(p,lson);
    }
    else
    {
       modify(p,rson);
    }
    node[rt]=node[rt<<1]+node[rt<<1|1];
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        return node[rt];
    }
    int m=(l+r)>>1;
    int sum=0;
    if(L<=m)
    {
        sum+=query(L,R,lson);
    }
   if(R>m)
    {
        sum+=query(L,R,rson);
    }
    return sum;
}
int main()
{
    int t,t1=0;
    scanf("%d",&t);
    while(t--)
    {
        int n,i;
        t1++;
        //memset(ans,0,sizeof(ans));
        scanf("%d",&n);
        build(1,n,1);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&m[i]);
            x[m[i]]=i;
        }
        for(i=n;i>=1;i--)
        {
            ans[m[i]]=query(1,m[i],1,n,1);
            modify(m[i],1,n,1);
        }
        printf("Case #%d:",t1);
        for(i=1;i<=n;i++)
        {
            if(x[i]<=i)
           printf(" %d",ans[i]);
           else
           {
               printf(" %d",ans[i]+abs(x[i]-i));
           }
        }
        printf("\n");
    }
    return 0;
}
weixin073智慧旅游平台开发微信小程序+ssm后端毕业源码案例设计 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值