1002 A+B for Polynomials (25)

目录

题目:

解题思路:

C语言实现:


题目:

1002 A+B for Polynomials (25)(25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

解题思路:

        多项式相加,幂数相同的项系数相加,系数为零的项不用打印。这里用数组下标表示多项式幂数,对应的数组值保存多项式系数。

        一开始没看懂题目意思,思路参考自该博文

C语言实现:

#include<stdio.h>

int main(int argc, char** argv) {
	int k=0;
	int local=0;			//多项式幂数 
	float temp=0;			//多项式系数 
	float A[1001]={0.0};	        //结果数组 
	scanf("%d",&k);
	while(k--){			//存入第一个多项式 
		scanf("%d%f",&local,&temp);
		A[local]+=temp;
	}
	scanf("%d",&k);
	while(k--){			//加上第二个多项式 
		scanf("%d%f",&local,&temp);
		A[local]+=temp;
	}
	k=0;				//统计非零项 
	for(int i=0;i<1001;++i){
		if(A[i]!=0.0){
			++k;
		}
	}
	printf("%d",k);
	if(k!=0){
		printf(" ");
	}
	for(int i=1000;i>=0&&k>0;--i){
		if(A[i]!=0.0){
			printf("%d ",i);
			printf("%g",A[i]);
			--k;
			if(k!=0){
				printf(" ");
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值