数据结构实验之链表四:有序链表的归并

Problem Description
分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。
Input
第一行输入M与N的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。
Output
输出合并后的单链表所包含的M+N个有序的整数。
Sample Input
6 5
1 23 26 45 66 99
14 21 28 50 100
Sample Output
1 14 21 23 26 28 45 50 66 99 100

代码:

#include <stdio.h>
#include <stdlib.h>
struct st
{

    int date;

    struct st *next;

};

struct st *f(int n)
{   struct st *h,*q,*p;
  int i;
    h=(struct st *)malloc(sizeof(struct st));
    h->next=NULL;
    q=h;
    for(i=0;i<n;i++)
    {
        p=(struct st*)malloc(sizeof(struct st));
        scanf("%d",&p->date);
        p->next=NULL;
        q->next=p;
        q=p;

    }
   return h;
};
struct st *merge(struct st *h1,struct st *h2){
    struct st *p1,*p2,*z;
    p1=h1->next;
    p2=h2->next;
    z=h1;
    free(h2);
    z->next=NULL;
    while(p1&&p2)
    {
         if(p1->date<p2->date)
    {
        z->next=p1;
        z=p1;
        p1=p1->next;
        z->next=NULL;

    }
    else {
        z->next=p2;
        z=p2;
        p2=p2->next;
        z->next=NULL;
    }

    }
    while(p2)
    {
       z->next=p2;
       z=p2;         
       p2=p2->next;     \\或者去掉后三行
       z->next=NULL;

        }
    while(p1)

   {   z->next=p1;
       z=p1;
       p1=p1->next;     \\或者去掉后三行
       z->next=NULL;


   }
    return h1;

    };


    void print(struct st *h)
    {
        struct st *g;
         g=h->next;
    while(g)
    {
        if(g->next==NULL)
        printf("%d\n",g->date);
        else printf("%d ",g->date);
        g=g->next;
    }
    }

int main()

{
    struct  st *h1,*h2,*h;
    int n,m;
    scanf("%d%d",&n,&m);
    h1=f(n);
    h2=f(m);
    h=merge(h1,h2);
    print(h);




    return 0;

}

无函数版的:



#include <stdio.h>
#include <stdlib.h>
struct st
{

    int date;

    struct st *next;

};
int main()

{
    struct  st *h1,*h2,*q,*p,*p1,*p2,*z;
    int n,m,i;
    scanf("%d%d",&n,&m);
    h1=(struct st *)malloc(sizeof(struct st));
    h1->next=NULL;
    q=h1;
    for(i=0;i<n;i++)
    {
        p=(struct st*)malloc(sizeof(struct st));
        scanf("%d",&p->date);
        p->next=NULL;
        q->next=p;
        q=p;
    }
    h2=(struct st *)malloc(sizeof(struct st));
    h2->next=NULL;
    q=h2;
    for(i=0;i<m;i++)
    {
        p=(struct st*)malloc(sizeof(struct st));
        scanf("%d",&p->date);
        p->next=NULL;
        q->next=p;
        q=p;
    }
    p1=h1->next;
    p2=h2->next;
    z=h1;
    free(h2);
    z->next=NULL;
    while(p1&&p2)
    {
         if(p1->date<p2->date)
    {
        z->next=p1;
        z=p1;
        p1=p1->next;
        z->next=NULL;

    }
    else {
        z->next=p2;
        z=p2;
        p2=p2->next;
        z->next=NULL;
    }

    }
    while(p2)
    {
       z->next=p2;
       z=p2;
       p2=p2->next;
       z->next=NULL;

        }
    while(p1)

   {   z->next=p1;
       z=p1;
       p1=p1->next;
       z->next=NULL;


   }
     p=h1->next;
      while(p)
       {
        if(p->next==NULL)
        printf("%d\n",p->date);
        else printf("%d ",p->date);
        p=p->next;
      }



    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值