ACM-ICPC 2018 徐州赛区网络预赛F

博客讲述了Morgana在学习计算机视觉时如何从猫的视频中提取特征,并寻找猫的运动轨迹。他关注每个帧中的猫特征,这些特征是二维向量。如果特征在连续帧中出现,就构成了特征运动。文章提供了输入输出格式,并给出了一组测试实例,旨在找出最长的特征运动序列长度。
摘要由CSDN通过智能技术生成

Morgana is learning computer vision, and he likes cats, too. One day he wants to find the cat movement from a cat video. To do this, he extracts cat features in each frame. A cat feature is a two-dimension vector <x, y>. If x_ixi​ = x_jxj​and y_iyi​ = y_jyj​, then <x_ixi​, y_iyi​> <x_jxj​, y_jyj​> are same features.

So if cat features are moving, we can think the cat is moving. If feature <aa, bb> is appeared in continuous frames, it will form features movement. For example, feature <aa , bb > is appeared in frame 2,3,4,7,82,3,4,7,8, then it forms two features movement 2-3-42−3−4 and 7-87−8 .

Now given the features in each frames, the number of features may be different, Morgana wants to find the longest features movement.

Input

First line contains one integer T(1 \le T \le 10)T(1≤T≤10) , giving the test cases.

Then the first line of each cases contains one integer nn (number of frames),

In The next nn lines, each line contains one integer k_iki​ ( the number of features) and 2k_i2ki​ intergers describe k_iki​features in ith frame.(The first two integers describe the first feature, the 33rd and 44th integer describe the second feature, and so on).

In each test case the sum number of features NN will satisfy N \le 100000N≤100000 .

Output

For each cases, output one line with one integers represents the longest length of features movement.

样例输入复制

1
8
2 1 1 2 2
2 1 1 1 4
2 1 1 2 2
2 2 2 1 4
0
0
1 1 1
1 1 1

样例输出复制

3

 

1组测试实例,8行,每一行第一个是说当前行有几个点

如果当前行中和上一行有相同点,说明这个点连续,

那么求最大的连续次数(例如示例中1,1点连续3次,所以输出3)

 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
struct Node{
    int x,y;
    bool operator < (const Node &a) const{
        if(x!=a.x)
            return x<a.x;
        return y<a.y;
    }
};
map<Node,int> M[2];
int main()
{
    int t,n,m,x,y;
    scanf("%d",&t);

    while(t--)
    {
        scanf("%d",&n);
        int ans = 0,flag = 0;
        for(int i=0;i<n;i++)
        {
            M[flag].clear();
            scanf("%d",&m);
            if(!m)
                continue;
            while(m--)
            {
                scanf("%d%d",&x,&y);
                Node P;
                P.x = x;
                P.y = y;
                if(M[!flag].count(P))
                {
                    M[flag][P] = M[!flag][P]+1;
                    ans = max(ans,M[flag][P]);
                }
                else
                    M[flag][P]=1,ans = max(ans,M[flag][P]);
            }
            flag = !flag;
        }
        printf("%d\n",ans);
    }

    return 0;
}

好吧,被发现了小bug,已改正,是上面continue的问题

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
struct Node{
    int x,y;
    bool operator < (const Node &a) const{
        if(x!=a.x)
            return x<a.x;
        return y<a.y;
    }
};
map<Node,int> M[2];
int main()
{
    int t,n,m,x,y;
    scanf("%d",&t);

    while(t--)
    {
        scanf("%d",&n);
        int ans = 0,flag = 0;
        for(int i=0;i<n;i++)
        {
            M[flag].clear();
            scanf("%d",&m);
            while(m--)
            {
                scanf("%d%d",&x,&y);
                Node P;
                P.x = x;
                P.y = y;
                if(M[!flag].count(P))
                {
                    M[flag][P] = M[!flag][P]+1;
                    ans = max(ans,M[flag][P]);
                }
                else
                    M[flag][P]=1,ans = max(ans,M[flag][P]);
            }
            flag = !flag;
        }
        printf("%d\n",ans);
    }

    return 0;
}

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值