A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as ∑i=0k(aibi). Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes
if N is a palindromic number in base b, or No
if not. Then in the next line, print N as the number in base b in the form "ak ak−1 ... a0". Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
digits改成char类型,cout<<digits[i]-'\0'<<" ";这样的话,测试点4就过不了,还没想到原因。。。
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main(){
unsigned long n,b;
cin>>n>>b;
if(n==0){
cout<<"Yes"<<endl;
cout<<"0";
return 0;
}
vector<int>digits;
while(n){
digits.push_back(n%b);
n/=b;
}
int flag=0;
for(int i=0;i<digits.size()/2;i++){
if(digits[i]!=digits[digits.size()-i-1]){
flag=1;
break;
}
}
if(flag==1)
cout<<"No"<<endl;
else
cout<<"Yes"<<endl;
for(int i=digits.size()-1;i>0;i--)
cout<<digits[i]<<" ";
cout<<digits[0];
return 0;
}