杭电2099-整除的尾数

Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
 

Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
 

Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
 

Sample Input
  
  
200 40 1992 95 0 0
 

Sample Output
  
  
00 40 80

15

AC代码如下:

#include "stdio.h"
int main()
{
    int y,a,b,count;
    while(scanf("%d%d",&a,&b)!=EOF&&a&&b)
    {
        y=(a*100)%b;
        if(y==0)
        {
            count=0;
            while(count<100-b)
            {
                if(count<10) 
                    printf("0%d ",count);
                else
                    printf("%d ",count);
                count+=b;
            }
            if(count<10)
                printf("0%d",count);
            else 
                printf("%d",count);
        }
        else
        {
            count=b-y;
            while(count<100-b)
            { 
                if(count<10) 
                    printf("0%d ",count);
                else 
                    printf("%d ",count);
                count+=b;
            }
            if(count<10)
                printf("0%d",count);
            else 
                printf("%d",count);
        }
        printf("\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值