杭电1896(题意详解+代码)(优先队列)之Stones

Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
  
  
11

12

题目大意:

一个人在路上从0位置出发,从左往右走,第奇数次遇到石头就把它往右扔出去,偶数次遇到石头就不管它,当他在某个位置遇到两个或两个以上的石头,最先遇到的将是d值最小的那个,然后依次按d值从小到大的书序遇到该位置上的石头,计算 他扔的 最后那块石头离起点的距离??? 看一下下面的案例就懂了

分析::

4

1 5

2 4

3 3

4 2

1 2 3 4 >> 2 3 4 6 >> (2) 3 4 6 >> 4 6<2> >> (4) 6<2> >> 6 9 >> (6) 9 >> 12

5 4 3 2 4 3 2 5 4 3 2 5 4 3,5 4 3,5 5 3 5 3  

5

1 5

2 4

3 3

7 8

8 100

输出 208

建立坐标轴: 

初始状态: 1 2 3 7 8 >>> 一、 2 3 6 7 8 >>> 二、 (2) 3 6 7 8 >>> 三、6<2> 7 8 >>> 四、(6) 6 7 8 >>> ...

5 4 3 8 100 4 3 5 8 100 3 5 8 100 5、3 7 100 3 5 8 100

.... >>> 五、7 8 11 >>> 六、 (7) 8 11 >>> 七、 11 108 >>>八、 (11) 108 >>> 九、 208

8 100 5 8 100 5 5 100 5 100

解释说明:

1, ...>>>...>>>...表示位置信息Pi,下面一排数表示对应位置的石头能扔的距离Di

2, 一、 表示第一次遇到石头操作后的结果, 二、 表示第二次遇到石头操作后的结果

3, (n) 表示n这个石头被跳过了,所以有()的那次操作,前面的中文数字必定是偶数  

4, n<m> 表示n位置有m个石头   

5, n,m 表示当前为有两块石头,并且两块石头可以扔的距离分别为n和m

T组测试案例,n表示石头数量, 每组有n对数,Pi,Di; 分别表示第i块石头所在位置,和第i块石头能扔的距离

思路:涉及 动态排序+最优问题 ,故用 优先队列 解决

AC代码如下:

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;

struct Node  //石头信息
{
    int p;
    int d;
};

struct cmp
{
    bool operator() (const Node a,const Node b)const   //a优先级小于b,返回true
    {
        if(a.p==b.p) return a.d>b.d;
        else return a.p>b.p;
    }
};

int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        priority_queue <Node,vector<Node>,cmp> pq;  //定义优先队列
        Node node;
        cin>>n;
        while(!pq.empty()) pq.pop();    //清空队列
        for(int i=0;i<n;i++)
        {
            cin>>node.p>>node.d;     //入队列
            pq.push(node);
        }
        int flag=1;                 //记录遇到石头的次数
        while(!pq.empty())
        {
            node=pq.top(); pq.pop();
            if(flag%2==1)
            {
                node.p+=node.d;
                pq.push(node);
            }
            flag++;
        }
        cout<<node.p<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Java中的优先队列可以通过小顶堆或大顶堆来实现。小顶堆是指优先级最小的元素在队列头部,大顶堆则相反,优先级最大的元素在队列头部。在Java中,可以通过PriorityQueue类来实现优先队列,其中默认是小顶堆实现。如果需要使用大顶堆实现,则可以通过传入一个比较器来实现。以下是两种实现方式的示例代码: 1. 小顶堆实现: ```java PriorityQueue<Integer> pq = new PriorityQueue<Integer>(); ``` 2. 大顶堆实现: ```java PriorityQueue<Integer> pq = new PriorityQueue<Integer>((x,y) -> y-x); ``` 关于应用方面,LeetCode题目中有一道关于优先队列的题目,即“最后一块石头的重量”。题目描述如下:有一堆石头,每块石头的重量都是正整数。每一回合,从中选出两块最重的石头,然后将它们一起粉碎。假设石头的重量分别为x和y,且x <= y。那么粉碎的可能结果如下: - 如果x == y,那么两块石头都会被完全粉碎; - 如果x != y,那么重量为x的石头将会完全粉碎,而重量为y的石头新重量为y-x。 最终,当只剩下一块石头时,返回这块石头的重量。可以使用优先队列来解决这个问题,具体实现方式为:将所有石头的重量加入到优先队列中,然后每次取出队列中最大的两个元素进行粉碎,将粉碎后的结果再加入到队列中,直到队列中只剩下一个元素为止。以下是示例代码: ```java public int lastStoneWeight(int[] stones) { PriorityQueue<Integer> pq = new PriorityQueue<Integer>((x,y) -> y-x); for(int stone : stones) { pq.offer(stone); } while(pq.size() > 1) { int x = pq.poll(); int y = pq.poll(); if(x != y) { pq.offer(y-x); } } return pq.isEmpty() ? 0 : pq.poll(); } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值