杭电5984之Pocky

Pocky

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 415 Accepted Submission(s): 211


Problem Description
Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input
The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output
For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input
  
  
6 1.0 1.0 2.0 1.0 4.0 1.0 8.0 1.0 16.0 1.0 7.00 3.00

Sample Output
  
  
0.000000 1.693147 2.386294 3.079442 3.772589

1.847298

分析:不多说,就是凑出来的,不过要注意实数相等的条件是,它们之差的绝对值小于1e-8

AC代码如下:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

bool fun(double a,double b)//判断两个实数是否相等
{
    if(a-b<=1e-8) return true;
    else return false;
}

int main()
{
    int t;
    double a,b;
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        if(fun(a,b))
            printf("0.000000\n");
        else
            printf("%.6lf\n",log(a/b)+1);
    }
    return 0;
}



 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值