杭电1039 之 Easier Done Than Said?


Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
  
  
a tv ptoui bontres zoggax wiinq eep houctuh end

Sample Output
  
  
<a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable.

<houctuh> is acceptable.

题意:给你一个字符串,如果它满足以下三个条件,它就是合法的密码,否则不合法

1、至少包含一个元音字母

2、不包含三个连续的元音字母,同时 不包含三个连续的辅音字母

3、不包含两个连续的相同的字母,“ee”和“oo”除外

AC代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;

bool isvowel(char c)
{
    if(c=='a' || c=='e' || c=='i' || c=='o' || c=='u') return true;
    return false;
}

bool ispassword1(string str)
{
    for(int i=0;i<str.length();i++)
    {
        if(isvowel(str[i])) return true;
    }
    return false;
}

bool ispassword2(string str)
{
    for(int i=0;i<str.length();i++)
    {
        if(i+2<str.length() && isvowel(str[i]) && isvowel(str[i+1]) && isvowel(str[i+2]))
        {
            return false;
        }
        else if(i+2<str.length() && !isvowel(str[i]) && !isvowel(str[i+1]) && !isvowel(str[i+2]))
        {
            return false;
        }
    }
    return true;
}

bool ispassword3(string str)
{
     for(int i=0;i<str.length();i++)
     {
         if(i+1<str.length() && str[i+1]==str[i] && str[i]!='e' && str[i]!='o') return false;
     }
     return true;
}

bool ispassword(string str)
{
    if(ispassword1(str) && ispassword2(str) && ispassword3(str)) return true;
    return false;
}

int main()
{
    string str;
    while(cin>>str)
    {
        if(str=="end") break;
        if(ispassword(str))
            cout<<"<"<<str<<"> is acceptable."<<endl;
        else
            cout<<"<"<<str<<"> is not acceptable."<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值