杭电 Kolakoski

Problem Description
This is Kolakosiki sequence: 1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1 . This sequence consists of 1 and 2 , and its first term equals 1 . Besides, if you see adjacent and equal terms as one group, you will get 1,22,11,2,1,22,1,22,11,2,11,22,1 . Count number of terms in every group, you will get the sequence itself. Now, the sequence can be uniquely determined. Please tell HazelFan its n th element.
 

Input
The first line contains a positive integer T(1T5) , denoting the number of test cases.
For each test case:
A single line contains a positive integer n(1n107) .
 

Output
For each test case:
A single line contains a nonnegative integer, denoting the answer.
 

Sample Input
  
  
2 1 2
 

Sample Output
  
  
1

2

思路:Kolakoski数列,

Kolakoski序列是一个仅由1和2组成的无限数列,是一种通过“自描述”来定义的数列 [1]   。他的前几项为
1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1,2,1,1,2,1,2,2,1,1,…( OEIS上的A000002)
它的定义很简单,若把数列中相同的数定为一组,令a(1)=1,a(2)=2,则a(n)等于第n组数的长度。
可以根据这个定义来推算第三项以后的数:例如由于a(2)=2,因此第2组数的长度是2,因此a(3)=2,;
由于a(3)=2,所以第三组数的长度是2,因此a(4)=a(5)=1;由于a(4)=1,a(5)=1,所以第四组数和第五组数的长度都为1,因此a(6)=2,a(7)=1,以此类推。 [2]  

根据该定义 模拟+打表 即可

AC代码如下:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn=1e7+10;
int a[maxn];

int main()
{
    int t;
    int n;
    a[1]=1;
    a[2]=2;
    a[3]=2;
    int cur=3;
    int flag=2;
    for(int i=4;i<maxn;)
    {
        int num=a[cur];
        for(int j=0;j<num;j++)
        {
            if(flag==2)
                a[i]=1;
            else
                a[i]=2;

            if(j==num-1) flag=a[i];
            i++;
        }
        cur++;
    }
    cin>>t;
    while(t--)
    {
        cin>>n;
        cout<<a[n]<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值