题目描述
编写一个程序,输入一个字符串(长度不超过80),然后统计出该字符串当中包含有多少个单词。例如:字符串“this is a book”当中包含有4个单词。
输入描述
输入一个字符串,由若干个单词组成,单词之间用一个空格隔开。
输出描述
输出一个整数,即单词的个数。
输入样例
this is a book
输出样例
4
AC代码如下:
#include "iostream"
#include "cstdio"
#include "cstring"
#include "cstdlib"
using namespace std;
char a[1000];
int main(int argc, char* argv[])
{
int ans=0;
gets(a);
int len=strlen(a);
for(int i=0;i<len;i++)
{
if(a[i]==' ')
{
ans++;
while (a[i]==' ')
{
i++;
}
}
}
cout<<ans+1<<endl;
return 0;
}