[USACO14MAR]浇地Watering the Fields【洛谷P2212】

题目描述

Due to a lack of rain, Farmer John wants to build an irrigation system to

send water between his N fields (1 <= N <= 2000).

Each field i is described by a distinct point (xi, yi) in the 2D plane,

with 0 <= xi, yi <= 1000. The cost of building a water pipe between two

fields i and j is equal to the squared Euclidean distance between them:

(xi - xj)^2 + (yi - yj)^2

FJ would like to build a minimum-cost system of pipes so that all of his

fields are linked together – so that water in any field can follow a

sequence of pipes to reach any other field.

Unfortunately, the contractor who is helping FJ install his irrigation

system refuses to install any pipe unless its cost (squared Euclidean

length) is at least C (1 <= C <= 1,000,000).

Please help FJ compute the minimum amount he will need pay to connect all

his fields with a network of pipes.

农民约翰想建立一个灌溉系统,给他的N (1 <= N<= 2000)块田送水。农田在一个二维平面上,第i块农田坐标为(xi,yi)(0 <= xi , yi <= 1000),在农田iii 和农田jjj 自己铺设水管的费用是这两块农田的欧几里得距离的平方(xi−xj)2+(yi−yj)2

农民约翰希望所有的农田之间都能通水,而且希望花费最少的钱。但是安装工人拒绝安装费用小于C的水管(1 <= C<= 1,000,000)。

请帮助农民约翰建立一个花费最小的灌溉网络,如果无法建立请输出-1。

输入输出格式

输入格式:

  • Line 1: The integers N and C.

  • Lines 2…1+N: Line i+1 contains the integers xi and yi.

输出格式:

  • Line 1: The minimum cost of a network of pipes connecting the

fields, or -1 if no such network can be built.

输入输出样例

输入样例#1: 复制

3 11
0 2
5 0
4 3

输出样例#1: 复制

46

说明

INPUT DETAILS:

There are 3 fields, at locations (0,2), (5,0), and (4,3). The contractor

will only install pipes of cost at least 11.

OUTPUT DETAILS:

FJ cannot build a pipe between the fields at (4,3) and (5,0), since its

cost would be only 10. He therefore builds a pipe between (0,2) and (5,0)

at cost 29, and a pipe between (0,2) and (4,3) at cost 17.

Source: USACO 2014 March Contest, Silver

思路

kruskal的板子题,注意数组大小要开够
如果遇到边权小于c的边就不加了

code

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
int X[2005],Y[2005];
int fa[4000005];
int tot=0,n,c;
struct node
{
    int x,y,wgt;
}e[4000005]; 
bool cmp(node a,node b)
{
    return a.wgt<b.wgt; 
}
int find(int x) 
{
    if(fa[x]==x)return x;
    else
    	return fa[x]=find(fa[x]);
}
int addedge(int a,int b,int c)
{
    e[++tot].x=a;
	e[tot].y=b;
	e[tot].wgt=c;
}
int dis(int xi,int yi,int xj,int yj)
{
    return (xi-xj)*(xi-xj)+(yi-yj)*(yi-yj);
}
int Kruskal()
{
    sort(e+1,e+1+tot,cmp);
    int ans=0,j=0;
    for(int i=1;i<=n;i++)
		fa[i]=i;
    for(int i=1;i<=tot;i++)
    {
        int u=find(e[i].x);
        int v=find(e[i].y);
        if(u!=v) 
        {
            fa[u]=v;
            ans+=e[i].wgt;
            j++;
        }
        if(j==n-1)break;
    }
    if(j==n-1)
        printf("%d\n",ans);
    else 
		printf("-1\n");
    return 0;
}
int main()
{
    scanf("%d%d",&n,&c);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&X[i],&Y[i]);
        for(int j=1;j<i;j++)
        {
            int Dis=dis(X[i],Y[i],X[j],Y[j]);
            if(Dis>=c)
                addedge(i,j,Dis);
        }
    }
    Kruskal();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值