Summer day 5

上午训练赛,果断前三题。后面两题也就限于看看题解了。

1. Digit Generator

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1 N 100, 000 .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.
The following shows sample input and output for three test cases.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

无聊的暴力题。一次AC。

#include<cstdio>

int n;

void solve(int num)
{
    int ans;
    int cnt = 1;
    int numr = num;
    while(numr >10)
    {
        numr = numr/10;
        cnt++;
    }
    int flag = 0;
    for(int s = num - 9*cnt; s<num; s++)
    {
        int digit_sum = 0;
        int sr = s;
        while(sr>=1)
        {
            digit_sum += sr%10;
            sr = sr/10;
        }
        if(s+digit_sum == num){flag = 1; ans = s; break;}
    }
    if(flag == 1)   printf("%d\n",ans);
    else    printf("0\n");
    return;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        solve(n);
    }
    return 0;
}

2. Hangman Judge

吊死鬼模拟。
day 1做过。
Summer day 1

3. Maximum Product

自己写了一直没过,边界什么都考虑了。
惊讶的发现之前做过这道题的题解。
柳暗花明又一村。
对比之后仍然不知道为什么这次写的没过。
至于用DP,我就看看= =。
Uva 11059 Maximum Product

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值