PAT A 1009

题目

求两个多项式的积
输入格式为两行,每行第一个数表示这个多项式非零项的个数k, 接下来的每两个数据表示次数和该次数的系数,共k组。

I/O

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

算法

由于k<=10,直接暴力求多项式系数,不必用什么矩阵了。但貌似C++里面有计算的STL,没去研究过。
数组开大一点,至少2001。

代码

#include <cstdio>
#include <cstring>
#include <cmath>

double expo[3][10100];
int maxexp[3];

void product()
{   for(int i = 0; i<=maxexp[0]; i++)
    {   for(int j = 0; j<=maxexp[1]; j++)
        {   expo[2][i+j]+=expo[0][i]*expo[1][j];
            if(i+j>maxexp[2]) maxexp[2] = i+j;
        }
    }
    int cnt = 0;
    for(int i = 0; i<=maxexp[2]; i++)
    {   if(fabs(expo[2][i])>=0.00001)
        cnt++;
    }
    printf("%d", cnt);
    for(int i = maxexp[2]; i>=0; i--)
    {   if(fabs(expo[2][i])>=0.00001)
            printf(" %d %.1lf", i, expo[2][i]);
    }
    return;
}

int main()
{   memset(expo, 0, sizeof(expo));
    memset(maxexp, 0, sizeof(maxexp));
    for(int i = 0; i<2; i++)
    {   int k;
        scanf("%d", &k);
        while(k--)
        {   int e;
            double c;
            scanf("%d %lf",&e, &c);
            expo[i][e]+=c;
            if(e>maxexp[i]) maxexp[i] = e;
        }
    }
    product();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值