HDU_1879 畅通工程(最小生成树)

继续畅通工程

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16631    Accepted Submission(s): 7149


Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
 

Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input
  
  
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output
  
  
3 1 0
 

题意:

从题意可以看出是一道最小生成树,用Kruscal感觉会更方便一点,但对于已经修好的路我们要特殊处理,相当于权值为0,这样就会优先选择已经修好的路来完成连通图。

代码实现:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
//#include <bits/stdc++.h>
#define MAX 105
#define INF 0xfffffff
using namespace std;

int N;
int weight;
struct edge{
    int from,to;
    int cost;
};
int Rank[MAX];              //树的高度
int Father[MAX];            //父亲
edge edges[MAX*MAX];        //边集数组
int Find(int x);
void ini(int V);
int Kruscal();
bool same(int x,int y);
void Unite(int x,int y);
bool comp(const edge& e1, const edge& e2);
int main()
{
    while( scanf("%d",&N)!=EOF && N != 0 )
    {
        int a,b,cos,flag;
        ini(N);
        for( int i = 0; i < N*(N-1)/2; i++ )
        {
            scanf("%d%d%d%d",&a,&b,&cos,&flag);
            if( flag )
                cos = 0;
            edges[i].from = a;
            edges[i].to = b;
            edges[i].cost = cos;
        }
        weight = Kruscal();
        printf("%d\n",weight);
    }
    return 0;
}


int Kruscal()
{
    sort(edges,edges+N*(N-1)/2,comp);
    int res = 0;
    int num = 0;
    int times = N*(N-1)/2;
    for( int i = 0; i < times; i++ )
    {
        edge e = edges[i];
        if( !same( e.from, e.to ) )
        {
            Unite(e.from,e.to);
            res += e.cost;
            num++;
        }
        //优化,连通图的边数为N-1
        if( num == N-1 )
            break;
    }
    return res;
}

bool comp(const edge& e1, const edge& e2)
{
    return e1.cost < e2.cost;
}

bool same( int x,int y)
{
    return Find(x) == Find(y);
}

int Find(int x)
{
    int k,j,r;
    r = x;
    while( r != Father[r] )
        r = Father[r];
    k = x;
    while( k != r )
    {
        j = Father[k];
        Father[k] = r;
        k = j;
    }
    return r;
}

void Unite(int x,int y)
{
    x = Find(x);
    y = Find(y);
    if( x == y )
        return ;
    if( Rank[x] < Rank[y] )
        Father[x] = y;
    else
    {
        Father[y] = x;
        if( Rank[x] == Rank[y] )
            Rank[x]++;
    }
    return ;
}

void ini(int V)
{
    weight = 0;
    for( int i = 1; i <= V; i++ )
    {
        Father[i] = i;
        Rank[i] = 1;
    }
    return ;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值