<LeetCode OJ> 123. / 188. Best Time to Buy and Sell Stock (III / IV)

123. Best Time to Buy and Sell Stock III

My Submissions
Total Accepted: 49478  Total Submissions: 195107  Difficulty: Hard

Say you have an array for which the ith element is the price of a given stock on day i.

Design an algorithm to find the maximum profit. You may complete at most two transactions.

Note:
You may not engage in multiple transactions at the same time (ie, you must sell the stock before you buy again).

Subscribe to see which companies asked this question

Hide Tags
  Array Dynamic Programming
Show Similar Problems



分析:

本体和背包问题一样,有两个变量,第i天,交易第j次
定义子问题:f[i][j]表示前i天交易j次能得到的最大利润
1,

对于第i天的物品有两种选择情况:交易(买或者卖)或者不做任何交易
1)如果不做任何交易:
显然,此时的最大利润还是前一天的最大利润f[j][i] =f[i-1][j]
2)如果交易:
为了能在这一天获得最大利润如果执行交易显然只能卖股票(不能买),也就是说只能加上当前price[i]:
那么在加上此值price[i]之前的临时利润必须是最大的(可以反正法证明),我们称之为最大临时利润maxtmp,

即如果交易,f[j][i] = prices[i] +maxtmp;

综上两种情况,f[j][i] = max(f[j][i-1], prices[i] +maxtmp);


继续求取maxtmp,
对于最大临时值maxtmp其实也是动态规划过程
显然遍历数组时求出最大,此时只有两种情况:每一次可以买,也可以不买
a)若不买:显然还是以前的maxtmp,即不变
b)若买:为了能最大显然是第j-1次的利润减去,f[i][j - 1] - price[i]

综上两种情况,maxtmp=max(maxtmp,f[i][j - 1] - price[i]

更具体的分析为:
那么假设第j次交易的买进股票是在第z天(实际上在那一天并不重要,我们只是要一个最大的临时值maxtmp即可) ,其中0<z<i,,那么必定有j-1次交易完成在z天以内,所以这一次交易的利润就是price[i] - price[z]
那么这种情况下的最大利润f[i][j] 就是 f[z][j-1] + price[i]-price[z]
那么当我们遍历到第i天,即在每次加上(遍历到)price[i]这个已知值时,先求出price[i]之前的f[z][j-1]-price[z]这个临时利润值maxtmp (必须是最大的,其实就是模拟:用手头已有的利润减去买股票的支出,所剩的还是最大)


综上所诉

f[j][i] = max(f[j][i-1], prices[i] +maxtmp);

maxtmp=max(maxtmp,f[i][j - 1] - price[i]);

class Solution {
public:
    int maxProfit(vector<int>& prices) {
        if (prices.size() < 2) 
            return 0;
        vector< vector<int> > f(3, vector<int>(prices.size(), 0));
        for (int j = 1; j <= 2; j++) {
            int tmpMax = f[j-1][0] - prices[0];
            for (int i = 1; i < prices.size(); i++) {
                f[j][i] = max(f[j][i-1], prices[i] + tmpMax);
                tmpMax = max(tmpMax, f[j-1][i] - prices[i]);
            }
        }
        return f[2][prices.size()-1];
    }
};




188. Best Time to Buy and Sell Stock IV

My Submissions
Total Accepted: 20293  Total Submissions: 97345  Difficulty: Hard

Say you have an array for which the ith element is the price of a given stock on day i.

Design an algorithm to find the maximum profit. You may complete at most k transactions.

Note:
You may not engage in multiple transactions at the same time (ie, you must sell the stock before you buy again).

Credits:
Special thanks to @Freezen for adding this problem and creating all test cases.

Subscribe to see which companies asked this question

Hide Tags
  Dynamic Programming
Show Similar Problems

分析:

见上面

class Solution {
public:
    int maxProfit(int k, vector<int>& prices) {
        if (k==0 || prices.size() < 2) 
            return 0;
        if (k > prices.size() / 2) {//测试案例尽然有这种情况,真是搞头都大了
            int maxProfit = 0;
            for (int i = 1; i < prices.size(); ++i)
                    maxProfit += max(0,prices[i] - prices[i - 1]);//贪心
            return maxProfit;
        }    
        vector< vector<int> > f(k+1, vector<int>(prices.size(), 0));//动态规划
        for (int j = 1; j <= k; j++) {
            int tmpMax = f[j-1][0] - prices[0];
            for (int i = 1; i < prices.size(); i++) {
                f[j][i] = max(f[j][i-1], prices[i] + tmpMax);
                tmpMax = max(tmpMax, f[j-1][i] - prices[i]);
            }
        }
        return f[k][prices.size()-1];
    }
};



参考以前博文中一道来自九度的问题:

题目1537:买卖股票

题目描述:

给定一个大小为n的数组,数组的元素a[i]代表第i天的股票价格。
设计一个算法,计算在最多允许买卖k次(一买一卖记为一次)的条件下的最大收益。
需要注意的是,你不能同时拥有两份股票。也就是说在下次买入前,你必须把手头上原有的股票先卖掉。

输入:

输入可能包含多个测试案例。
对于每个测试案例,输入的第一行为两个整数n和k(1<=n,k<=1000)。
输入的第二行包括n个整数,范围在[0,10000),代表数组中的元素。

输出:

对应每个测试案例,输出最大获益。

样例输入:
5 1
3 4 5 1 4
7 2
1 2 3 5 6 1 7
样例输出:
3
11
#include "algorithm"
#include <iostream>
#include "stack"
#include <cstring>
#include <cmath>  
 
using namespace std;
 
const int MAXN = 1010;
//每一天的股票价格
int price[MAXN];
//profit[i][j] 表示前i天交易j次能得到的最大利润
int profit[MAXN][MAXN];
 
 
int main() 
{
    int n, k; 
    //输入天数和交易次数
    while (cin >> n >> k)
    {//接受每天对应的价格
        for (int i = 1; i <= n; i++) 
            cin >> price[i];
        //初始化
        memset(profit, 0, sizeof(profit));
 
        for (int j = 1; j <= k; j++) 
        {
            int maxTmp = profit[0][j - 1] - price[1];
            for (int i = 1; i <= n; i++) 
            {
                //maxTmp保存着已完成的j-1次交易的最大利润减去买股票后的临时利润
                profit[i][j] = max(profit[i - 1][j], maxTmp + price[i]);//前者为不卖,后者为卖出时的最大利润
                //更新下一次的最大maxTmp:用手头的利润减去前一天(因为i增加了)买股票的钱
                maxTmp = max(maxTmp, profit[i][j - 1] - price[i]);//前者不买。后者买
            }
        }
        cout << profit[n][k] << endl;
 
    }
    return 0;
}
/**************************************************************
    Problem: 1537
    User: EbowTang
    Language: C++
    Result: Accepted
    Time:110 ms
    Memory:5508 kb
****************************************************************/



注:本博文为EbowTang原创,后续可能继续更新本文。如果转载,请务必复制本条信息!

原文地址:http://blog.csdn.net/ebowtang/article/details/50532742

原作者博客:http://blog.csdn.net/ebowtang



参考自己的博文:

【1】http://blog.csdn.net/ebowtang/article/details/45127659#t28

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值