程序设计入门 —— Java入门

1奇偶个数(5分)
题目内容:
你的程序要读入一系列正整数数据,输入-1表示输入结束,-1本身不是输入的数据。程序输出读到的数据中的奇数和偶数的个数。

输入格式:
一系列正整数,整数的范围是(0,100000)。如果输入-1则表示输入结束。

输出格式:
两个整数,第一个整数表示读入数据中的奇数的个数,第二个整数表示读入数据中的偶数的个数。两个整数之间以空格分隔。

输入样例:
9 3 4 2 5 7 -1

输出样例:
4 2
时间限制:500ms内存限制:32000kb

第一种:do-while

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int a1 = 0;
        int a2 = 0;
        int c = 0;
        do
        {
            c = in.nextInt();
            if(c == -1)
            {
                break;
            }
            else
            {
                if(c % 2 == 0)
                {
                    a1++;
                }
                else
                {
                    a2++;
                }
            }
        }while(c != -1);
        System.out.println(a1 + " " + a2);
    }

}

第二种: while

import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int a1 = 0;
        int a2 = 0;
        int c = in.nextInt();
        while(c != -1)
        {
            if(c % 2 == 0)
            {
                a1++;
            }
            else
            {
                a2++;
            }
            c = in.nextInt();
        }
        System.out.println(a2 + " " + a1);
    }

}
  • 0
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值