PAT:A1001 A+B Format (20 分)

PAT:A1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

代码:

C/C++:

#include<stdio.h>
#include<math.h>

int main() {
	int a, b, temp, i = 0;
	scanf("%d %d", &a, &b);
	temp = a + b;
	if(temp < 0) {
		printf("-");
		temp = -temp;
	}
	int str[10];
	if(temp == 0) str[i++] = 0; 
	while(temp != 0) {
		str[i++] = temp%10;
		temp = temp/10;
	}
	for(int j = i-1; j >= 0; j--) {
		printf("%d", str[j]);
		if(j != 0 && j % 3 == 0) printf(",");
	}
	return 0; 
}

Java:

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int a = in.nextInt();
        int b = in.nextInt();
        int c = a + b, len = 0;
        if(c < 0) {
            System.out.print("-");
            c = -c;
        }
        int arr[] = new int[10];
        do {
            arr[len++] = c % 10;
            c = c / 10;
        } while (c != 0);
        for (int i = len - 1; i >= 0; i--) {
            System.out.print(arr[i]);
            if(i != 0 && i % 3 == 0) {
                System.out.print(",");
            }
        }
    }
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值