C语言实验——单词统计

 

C语言实验——单词统计

Time Limit: 1000MS Memory Limit: 65536KB

 

Problem Description

从键盘输入一行字符(长度小于100),统计其中单词的个数,各单词以空格分隔,且空格数可以是多个。

Input

输入只有一行句子。仅有空格和英文字母构成。

Output

单词的个数。

Example Input

stable marriage  problem Consists     of Matching members

Example Output

7

 

 

 

 

#include<stdio.h>

#include<string.h>
int main(void)
{
   char str[100];
   int i, n, word = 0, num = 0;


   gets(str);
   n = strlen(str);
   for(i = 0; i < n; i++)
   {
       if(str[i] == ' ')
       {
           word  = 0;
       }
       else if(word == 0)
       {
           word = 1;
           num++;
       }
   }
   printf("%d\n", num);
   return 0;
}

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值