【题解】【PAT甲】1128 N Queens Puzzle (20 分)

27 篇文章 0 订阅

题目链接

 PTA | 程序设计类实验辅助教学平台

题目描述

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1​,Q2​,⋯,QN​), where Qi​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg

9q.jpg

Figure 1Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q1​ Q2​ ... QN​", where 4≤N≤1000 and it is guaranteed that 1≤Qi​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

结尾无空行

Sample Output:

YES
NO
NO
YES

结尾无空行

题目大意

 给你一些数据,其中第i个代表第几行,v[i]代表第几列有皇后,判断这个数据横行竖行斜行有没有其他的皇后,有的话输出NO,没有的话输出YES

解题思路

 一开始想用map<pair<int,int>,int>来存储那些点不能被取到,最后一个测试点会超时,然后就改为用二维数组来表示那些点能取哪些点不能取,然后循环还可以进行剪枝操作

因为需要让所有节点的横行和斜行都不能有数据,所以只需要从这个节点向后遍历,因为如果前面的节点和当前输入的节点有冲突的话,就直接可以判定为NO了,当这个节点和前面的节点没有冲突的时候,直接判断这个节点会不会和后面冲突就可以了,不用判断和前面的节点冲突,所以

for(int j=v;j<=n;j++)

for循环直接从当前值开始就可以了 

题解

#include<bits/stdc++.h>
using namespace std;
int v;
int g[1005][1005];
int main(){
	int t;
	cin>>t;
	while(t--){
		int n;
		memset(g,0,sizeof(g));
		scanf("%d",&n);
		bool f=true;
		for(int i=1;i<=n;i++){
			scanf("%d",&v);
			if(f){
				if(g[i][v]==1)	f=false;
				for(int j=v;j<=n;j++){
					g[j][v+abs(j-i)]=1;
					if((v+abs(j-i))>n)	break;
				}
				for(int j=v;j<=n;j++){
					g[j][v-abs(j-i)]=1;
					if((v-abs(j-i))<=0)	break;
				}
				for(int j=v;j<=n;j++){
					g[j][v]=1;
				}	
			}
		}
		if(f)	printf("YES\n");
		else	printf("NO\n");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值