【题解】【PAT甲】1131 Subway Map (30 分)(dfs)

27 篇文章 0 订阅

题目链接

 PTA | 程序设计类实验辅助教学平台

题目描述

In the big cities, the subway systems always look so complex to the visitors. To give you some sense, the following figure shows the map of Beijing subway. Now you are supposed to help people with your computer skills! Given the starting position of your user, your task is to find the quickest way to his/her destination.

subwaymap.jpg

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 100), the number of subway lines. Then N lines follow, with the i-th (i=1,⋯,N) line describes the i-th subway line in the format:

M S[1] S[2] ... S[M]

where M (≤ 100) is the number of stops, and S[i]'s (i=1,⋯,M) are the indices of the stations (the indices are 4-digit numbers from 0000 to 9999) along the line. It is guaranteed that the stations are given in the correct order -- that is, the train travels between S[i] and S[i+1] (i=1,⋯,M−1) without any stop.

Note: It is possible to have loops, but not self-loop (no train starts from S and stops at S without passing through another station). Each station interval belongs to a unique subway line. Although the lines may cross each other at some stations (so called "transfer stations"), no station can be the conjunction of more than 5 lines.

After the description of the subway, another positive integer K (≤ 10) is given. Then K lines follow, each gives a query from your user: the two indices as the starting station and the destination, respectively.

The following figure shows the sample map.

samplemap.jpg

Note: It is guaranteed that all the stations are reachable, and all the queries consist of legal station numbers.

Output Specification:

For each query, first print in a line the minimum number of stops. Then you are supposed to show the optimal path in a friendly format as the following:

Take Line#X1 from S1 to S2.
Take Line#X2 from S2 to S3.
......

where Xi's are the line numbers and Si's are the station indices. Note: Besides the starting and ending stations, only the transfer stations shall be printed.

If the quickest path is not unique, output the one with the minimum number of transfers, which is guaranteed to be unique.

Sample Input:

4
7 1001 3212 1003 1204 1005 1306 7797
9 9988 2333 1204 2006 2005 2004 2003 2302 2001
13 3011 3812 3013 3001 1306 3003 2333 3066 3212 3008 2302 3010 3011
4 6666 8432 4011 1306
3
3011 3013
6666 2001
2004 3001

结尾无空行

Sample Output:

2
Take Line#3 from 3011 to 3013.
10
Take Line#4 from 6666 to 1306.
Take Line#3 from 1306 to 2302.
Take Line#2 from 2302 to 2001.
6
Take Line#2 from 2004 to 1204.
Take Line#1 from 1204 to 1306.
Take Line#3 from 1306 to 3001.

结尾无空行

题目大意

 第一行输入n,k

n代表地铁线路,然后输入每条线路经过哪几站

k表示查询次数

给出起点和终点,让你求怎么坐的站最少,如果最少的路径不止一条,输出换乘最少的

解题思路

 自己一开始想的是用Dijkstra后来实现太麻烦了,参考柳婼代码

柳神(柳婼)PAT甲级题目链接_koori_145的博客-CSDN博客_柳神pat

发现直接dfs也不会超时

初始化

map<pair<int,int>,int> touch;    //两个车站直接是那一条地铁线
map<int,vector<int>> ma;        //当前站链接那个车站

ma是记录当前车站链接那些车站

touch是记录两个车站之间是哪一条地铁线

计算当前线路需要导几班车

int mintransfer(vector<int> v){		//计算倒几班车 
	int cnt=-1;         //是要倒几班车,不是做几班车,做几班车=倒几班车+1
	int preLine=-1;		//只要不等于上一条线就不行 
	for(int i=1;i<v.size();i++){
		if(touch[make_pair(v[i-1],v[i])]!=preLine)	cnt++;        
        //如果当前地铁线不等于上一条地铁线,说明倒车班数加一
		preLine = touch[make_pair(v[i-1],v[i])];
	}
	return cnt;
}

 dfs

void dfs(int x,int cnt){
	if(x==en&&(cnt<mmincnt||cnt==mmincnt&&mintransfer(tempPath)<minTranfer)){
        //判断更新
		mmincnt=cnt;
		minTranfer=mintransfer(tempPath);
		path=tempPath;
	}
	if(x==en)	return;
	if(cnt>=mmincnt)	return ;
    //剪枝
	for(int i=0;i<ma[x].size();i++){
		if(visited[ma[x][i]]==0){
			visited[ma[x][i]]=1;
			tempPath.push_back(ma[x][i]);
			dfs(ma[x][i],cnt+1);
			tempPath.pop_back();
			visited[ma[x][i]]=0;	
		} 
	}
}

 最后的输出

printf("%d\n",mmincnt);
int preTransfer=be;    //代表完成倒车或者初始状态的第一站的位置
int preLine=0;        //代表当前坐的是几号线
for(int j=1;j<path.size();j++){
	if(touch[make_pair(path[j-1],path[j])]!=preLine){
		if(preLine!=0)        //当preLine==0说明还是第一条线路
			printf("Take Line#%d from %04d to %04d.\n",preLine,preTransfer,path[j-1]);
		preLine=touch[make_pair(path[j-1],path[j])];
	    preTransfer = path[j-1];
	}
}
//因为上面for循环最后一班车没有输出,所以需要单独输出一下最后一条线路
printf("Take Line#%d from %04d to %04d.\n", preLine, preTransfer, en);

题解

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
map<pair<int,int>,int> touch;
map<int,vector<int>> ma;
vector<int> tempPath;
int visited[10005]; 
int mmincnt=INF;
int be,en;
int minTranfer=INF;
vector<int> path;
int mintransfer(vector<int> v){		//计算倒几班车 
	int cnt=-1;
	int preLine=-1;		//只要不等于上一条线就不行 
	for(int i=1;i<v.size();i++){
		if(touch[make_pair(v[i-1],v[i])]!=preLine)	cnt++;
		preLine = touch[make_pair(v[i-1],v[i])];
	}
	return cnt;
}
void dfs(int x,int cnt){
	if(x==en&&(cnt<mmincnt||cnt==mmincnt&&mintransfer(tempPath)<minTranfer)){
		mmincnt=cnt;
		minTranfer=mintransfer(tempPath);
		path=tempPath;
	}
	if(x==en)	return;
	if(cnt>=mmincnt)	return ;
	for(int i=0;i<ma[x].size();i++){
		if(visited[ma[x][i]]==0){
			visited[ma[x][i]]=1;
			tempPath.push_back(ma[x][i]);
			dfs(ma[x][i],cnt+1);
			tempPath.pop_back();
			visited[ma[x][i]]=0;	
		} 
	}
}
int main(){
	int n;
	cin>>n;
	int data;
	int pre;
	for(int i=1;i<=n;i++){
		int m;
		scanf("%d",&m);
		for(int j=0;j<m;j++){
			scanf("%d",&data);
			if(j!=0){
				ma[data].push_back(pre);
				ma[pre].push_back(data);
				touch[make_pair(pre,data)]=touch[make_pair(data,pre)]=i;
			}
			pre=data;
		}
	}
	int k;
	scanf("%d",&k);
	for(int i=0;i<k;i++){
		scanf("%d %d",&be,&en);
		mmincnt=INF;
		minTranfer=INF;
		tempPath.clear();
		tempPath.push_back(be);
		visited[be]=1;
		dfs(be,0);
		visited[be]=0;
		printf("%d\n",mmincnt);
		int preTransfer=be;
		int preLine=0;
		for(int j=1;j<path.size();j++){
			if(touch[make_pair(path[j-1],path[j])]!=preLine){
				if(preLine!=0)
					printf("Take Line#%d from %04d to %04d.\n",preLine,preTransfer,path[j-1]);
				preLine=touch[make_pair(path[j-1],path[j])];
				preTransfer = path[j-1];
			}
		}
		printf("Take Line#%d from %04d to %04d.\n", preLine, preTransfer, en);
	}
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值