【题解】【PAT甲】1098 Insertion or Heap Sort (25 分)(排序)(测试点4)

27 篇文章 0 订阅

题目链接

 PTA | 程序设计类实验辅助教学平台

题目描述

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

结尾无空行

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

结尾无空行

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题目大意

给你一个初始序列,再给一个经过几次排序的序列,判断序列使用堆排序还是用插入排序排序的,然后输出按这种排序下一步操作后的序列

解题思路

本题的关键是

插入排序n次,前n项元素是按顺序排好的

堆排序n次,后n项元素是按顺序排好的

插入排序的下一步就是将还未从小到大排序的元素加进去,重新sort一下就行了

while(l<=n&&b[l]>=b[l-1])	l++;    //找到从哪个开始
int f=l;
sort(b.begin()+1,b.begin()+f+1);    //直接加一个元素排序

 堆排序,看之前写的博客

【算法】堆排序_Elephant_King的博客-CSDN博客

现将已经完成的堆的根节点和未排序的最后一个节点交换,然后在更新堆

int r=n;
while(r>0&&b[r]>b[r-1])	r--;    //找到未排序好的最后一个节点
swap(b[1],b[r]);

测试点4错误的原因是有大小相等的重复元素,一开始判断序列前n项是否排序的时候是大于等于而不是大于

题解

#include<bits/stdc++.h>
using namespace std;
vector<int> a,b;
void heapSort(int l,int r){
	int i=l;	//当前节点 
	int j=i*2;	//当前节点的左孩子 
	while(j<=r){
		if(j+1<=r&&b[j]<b[j+1])	//找两个孩子哪个大	
			j++;				//将j的下标选择大的哪个 
		if(b[i]<b[j])			//如果最大的孩子节点大于本身 
			swap(b[i],b[j]);	//交换 
		else					//如果本身大于两个孩子节点,说明堆构建完成 
			break;
		i=j;					//继续向下遍历 
		j=i*2;
	}
}
int main(){
	int n;
	cin>>n;
	a.resize(n+1);
	b.resize(n+1);
	for(int i=1;i<=n;i++)	cin>>a[i];
	for(int i=1;i<=n;i++)	cin>>b[i];
	int l=2;
	while(l<=n&&b[l]>=b[l-1])	l++;
	int f=l;
	while(l<=n&&a[l]==b[l])	l++;
	if(l==n+1){
		cout<<"Insertion Sort"<<endl;
		sort(b.begin()+1,b.begin()+f+1);
	}
	else{
		cout<<"Heap Sort"<<endl;
		int r=n;
		while(r>0&&b[r]>b[r-1])	r--;
		swap(b[1],b[r]);
		heapSort(1,r-1);
	}
	for(int i=1;i<=n;i++){
		if(i!=1)	cout<<" ";
		cout<<b[i];
	} 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值