【题解】【PAT甲】1020 Tree Traversals(25分)(后序中序转层序)

27 篇文章 0 订阅
该博客介绍了如何从给定的二叉树后序和中序遍历序列中重建二叉树,并使用重建的树进行层序遍历。通过递归实现,将后序和中序转化为先序遍历,然后利用map存储层序遍历结果。算法重点在于找到根节点并递归处理左右子树。
摘要由CSDN通过智能技术生成

题目链接

 PTA | 程序设计类实验辅助教学平台

题目描述

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

结尾无空行

Sample Output:

4 1 6 3 5 7 2

结尾无空行

题目大意

 给出一棵树的中序和后序遍历结果,求这棵树的层序遍历

解题思路

 就相当于中序和后序遍历转换为先序遍历,其中每一个递归中的根节点就是需要找的节点

注意因为可能树的高度很高,所以最好不要用数组存层序遍历的数据,最好用map来存储

具体算法可以参考之前的文章

​​​​​​​​​​​​​​【算法】【树】已知后序中序序列求先序序列_Elephant_King的博客-CSDN博客

题解

#include<bits/stdc++.h>
using namespace std;
int n;
vector<int> in,post;
map<long long,int> ma;
void preOrder(int root,int start,int end,int index){
	if(start>end)	return ;
	int i=start;
	while(i<end&&in[i]!=post[root])	i++;
	ma[index]=post[root];
	preOrder(root-(end-i+1),start,i-1,index*2+1);
	preOrder(root-1,i+1,end,index*2+2);
}
int main(){
	cin>>n;
	in.resize(n);
	post.resize(n);
	for(int i=0;i<n;i++){
		cin>>post[i];
	}
	for(int i=0;i<n;i++){
		cin>>in[i];
	}
	preOrder(n-1,0,n-1,0);
	for(auto it=ma.begin();it!=ma.end();it++){
		if(it!=ma.begin())	cout<<" ";
		cout<<it->second;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值