【题解】【PAT甲】1146 Topological Order (25 分)(拓扑排序)(剪枝)(测试点4)

27 篇文章 0 订阅
该博客主要讨论了如何判断一个序列是否为有向图的拓扑排序。通过输入节点数、边数以及一系列的顶点序列,程序需要确定哪些序列不符合拓扑排序的条件。博主分享了一种解题思路,即遍历序列,检查每个节点是否存在未处理的入度,如果有则说明不是拓扑排序。同时,博主提到了剪枝技巧来优化算法,避免不必要的计算,以提高效率。
摘要由CSDN通过智能技术生成

题目链接

 PTA | 程序设计类实验辅助教学平台

题目描述

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
6
5 2 3 6 4 1
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

0 4 5

题目大意

 给一个有向图,然后判断给出的序列是不是拓扑排序的序列,不是的话就输出下标

解题思路

 没什么难度,输入一个节点,如果这个节点的竖列还有为1的节点,说明还有入度,不是拓扑排序,然后再把横排置零,删除这个节点的出度

需要注意的是剪枝问题,如果不剪枝测试点4会超时,具体的剪枝办法是,如果已经判断这个序列不是拓扑排序了,后面的输入判断就直接跳过就可以了,但是需要的等数据输入完再输出下标
 

	   bool f=false
       for(int i=1;i<=n;i++){
			int temp;
			scanf("%d",&temp);          //如果已经不是拓扑序列了,但是输入不能省
			if(!f){                    //如果f已经是true了,就没必要进去判断了
				for(int j=1;j<=n;j++){
					if(h[j][temp]==1){
						f=true;
						break;
					}
					h[temp][j]=0;
				}	
			}
		}

题解

#include<bits/stdc++.h>
using namespace std;
int g[1005][1005];
int h[1005][1005];
int main(){
	int m,n;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int a,b;
		scanf("%d %d",&a,&b);
		g[a][b]=1;
	}
	int k;
	cin>>k;
	int c=0;
	for(int x=0;x<k;x++){
		bool f=false;
		for(int j=1;j<=n;j++){
			for(int l=1;l<=n;l++){
				h[j][l]=g[j][l];
			}
		}
		for(int i=1;i<=n;i++){
			int temp;
			scanf("%d",&temp);
			if(!f){
				for(int j=1;j<=n;j++){
					if(h[j][temp]==1){
						f=true;
						break;
					}
					h[temp][j]=0;
				}	
			}
		}
		if(f){
			if(c==0)	c=1;
			else	printf(" ");
			printf("%d",x);
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值