Problem Description
输入3个字符串,按字典序从小到大进行排序。
Input
输入数据有一行,分别为3个字符串,用空格分隔,每个字符串长度不超过100。
Output
输出排序后的三个字符串,用空格分隔。
Example Input
abcd cdef bcde
Example Output
abcd bcde cdef
Hint
Author
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
char s[102],t[102],st[102];
char k[102];
scanf("%s%s%s",s,t,st);
//字符串之间的交换,需要调用函数strcpy()进行交换
if(strcmp(s,t)>0)
{
strcpy(k,s);
strcpy(s,t);
strcpy(t,k);
}
if(strcmp(s,st)>0)
{
strcpy(k,s);
strcpy(s,st);
strcpy(st,k);
}
if(strcmp(t,st)>0)
{
strcpy(k,t);
strcpy(t,st);
strcpy(st,k);
}
printf("%s %s %s",s,t,st);
printf("\n");
return 0;
}