USACO——Sorting a Three-Valued Sequence

Sorting a Three-Valued Sequence 
IOI'96 - Day 2

Sorting is one of the most frequently performed computational tasks. Consider the special sorting problem in which the records to be sorted have at mostthree different key values. This happens for instance when we sort medalists of a competition according to medal value, that is, gold medalists come first, followed by silver, and bronze medalists come last.

In this task the possible key values are the integers 1, 2 and 3. The required sorting order is non-decreasing. However, sorting has to be accomplished by a sequence of exchange operations. An exchange operation, defined by two position numbers p and q, exchanges the elements in positions p and q.

You are given a sequence of key values. Write a program that computes the minimal number of exchange operations that are necessary to make the sequence sorted.

PROGRAM NAME: sort3

INPUT FORMAT

Line 1:N (1 <= N <= 1000), the number of records to be sorted
Lines 2-N+1:A single integer from the set {1, 2, 3}

SAMPLE INPUT (file sort3.in)

9
2
2
1
3
3
3
2
3
1

OUTPUT FORMAT

A single line containing the number of exchanges required

SAMPLE OUTPUT (file sort3.out)

4
思路:统计1、2 、3个数a,b,c则分别在(0,a)、(a,a+b)、(a+b、a+b+c)区间内,于是在各区间内的移出不合适的数字,移入合适的位置即可


/*
ID: youqihe1
PROG: sort3
LANG: C++
*/
#include <iostream>
#include <fstream>
#include <string>
#include <string.h>

using namespace std;
struct data
{
    int val;
    int loc;
}A[1005];
int main() {
    FILE *fin  = fopen ("sort3.in", "r");
    FILE *fout = fopen ("sort3.out", "w");
    int n,a=0,b=0,c=0;
    fscanf(fin,"%d",&n);
    int i,j,k;
    for(i=0;i<n;i++)
    {
        fscanf(fin,"%d",&A[i].val);
        A[i].loc=i;
        switch(A[i].val)
        {
            case 1:a++;break;
            case 2:b++;break;
            case 3:c++;break;
        }
    }
    int ans=0;
    for(i=0;i<n;i++)
    {
        int lo=A[i].loc;
        int v=A[i].val;
        if(v==1)
        {
            if(lo<a)
                continue;
            else
            {
                int ele,ele2,flag=0;
                if(lo>=a&&lo<b)
                    ele=2,ele2=3;
                else
                    ele=3,ele2=2;
                for(j=0;j<a;j++)
                {
                    if(A[j].val==ele)
                    {
                        swap(A[j].val,A[i].val);
                        flag=1;
                        ans++;
                        break;
                    }
                }
                if(!flag)
                {
                    for(j=0;j<a;j++)
                    {
                        if(A[j].val==ele2)
                        {
                            swap(A[j].val,A[i].val);
                            ans++;
                            break;
                        }
                    }
                }
            }
        }
        else if(v==2)
        {
            if(lo>=a&&lo<a+b)
                continue;
            else
            {
                int ele,ele2,flag=0;
                if(lo<a)
                    ele=1,ele2=3;
                else
                    ele=3,ele2=1;
                for(j=a;j<a+b;j++)
                {
                    if(A[j].val==ele)
                    {
                        swap(A[j].val,A[i].val);
                        flag=1;
                        ans++;
                        break;
                    }
                }
                if(!flag)
                {
                    for(j=a;j<a+b;j++)
                    {
                        if(A[j].val==ele2)
                        {
                            swap(A[j].val,A[i].val);
                            ans++;
                            break;
                        }
                    }
                }
            }
        }
        else
        {
            if(lo>=a+b)
                continue;
            else
            {
                int ele,ele2,flag=0;
                if(lo<a)
                    ele=1,ele2=2;
                else
                    ele=2,ele2=1;
                for(j=a+b;j<a+b+c;j++)
                {
                    if(A[j].val==ele)
                    {
                        swap(A[j].val,A[i].val);
                        flag=1;
                        ans++;
                        break;
                    }
                }
                if(!flag)
                {
                    for(j=a+b;j<a+b+c;j++)
                    {
                        if(A[j].val==ele2)
                        {
                            swap(A[j].val,A[i].val);
                            ans++;
                            break;
                        }
                    }
                }
            }
        }
    }
    fprintf(fout,"%d\n",ans);
    return 0;
}




### 解题思路 "The Lost Cow" 是一道经典的模拟问题,目标是计算 Farmer John 找到 Bessie 需要行走的距离。Farmer John 使用一种特定的策略来寻找 Bessie:他从初始位置 `x` 开始,依次向右走一段距离,再返回原点;接着向左走更远的一段距离,再次回到原点,如此反复直到找到 Bessie。 #### 关键逻辑 1. **移动模式** 每次移动的距离按照序列 \( \pm 1, \mp 2, \pm 4, \ldots \) 增加,即每次翻倍并改变方向。 2. **终止条件** 当 Farmer John 到达的位置覆盖了 Bessie 的实际坐标 `y` 时停止搜索。具体来说: - 如果 `x < y`,则当某一次移动到达或超过 `y` 时结束; - 如果 `x > y`,则当某一次移动到达或低于 `y` 时结束。 3. **总路径长度** 计算总的路径长度时需要注意最后一次未完全完成的往返行程应减去多余的部分。 --- ### C++ 实现代码 以下是基于上述逻辑的一个标准实现: ```cpp #include <iostream> #include <cmath> using namespace std; int main() { long long x, y; cin >> x >> y; if (x == y) { cout << 0; return 0; } long long pos = x, step = 1, total_distance = 0; while (true) { // 向右移动 long long next_pos = pos + step; if ((x < y && next_pos >= y) || (x > y && next_pos <= y)) { total_distance += abs(y - pos); break; } total_distance += abs(next_pos - pos); pos = next_pos; // 返回起点 total_distance += abs(pos - x); // 向左移动 step *= -2; next_pos = pos + step; if ((x < y && next_pos >= y) || (x > y && next_pos <= y)) { total_distance += abs(y - pos); break; } total_distance += abs(next_pos - pos); pos = next_pos; // 返回起点 total_distance += abs(pos - x); step *= -2; } cout << total_distance; return 0; } ``` 此代码实现了 Farmer John 寻找 Bessie 的过程,并精确计算了所需的总路径长度[^1]。 --- ### Pascal 实现代码 如果偏好 Pascal,则可以参考以下代码片段: ```pascal var n, x, y, t, ans: longint; begin assign(input, 'lostcow.in'); reset(input); assign(output, 'lostcow.out'); rewrite(output); readln(x, y); if x = y then begin writeln(0); halt; end; n := x; t := 1; ans := 0; repeat ans := ans + abs(t) + abs(n - x); n := x + t; t := -t * 2; if ((n >= y) and (x < y)) or ((n <= y) and (x > y)) then begin ans := ans - abs(n - y); break; end; until false; writeln(ans); close(input); close(output); end. ``` 这段代码同样遵循相同的逻辑结构,适用于需要提交至 USACO 平台的情况[^3]。 --- ### Python 实现代码 对于初学者而言,Python 提供了一种更为简洁的方式表达这一算法: ```python def lost_cow(x, y): if x == y: return 0 position = x step = 1 total_distance = 0 while True: # Move to the right new_position = position + step if (x < y and new_position >= y) or (x > y and new_position <= y): total_distance += abs(new_position - position) total_distance -= abs(new_position - y) break total_distance += abs(new_position - position) position = new_position total_distance += abs(position - x) # Move to the left step *= -2 new_position = position + step if (x < y and new_position >= y) or (x > y and new_position <= y): total_distance += abs(new_position - position) total_distance -= abs(new_position - y) break total_distance += abs(new_position - position) position = new_position total_distance += abs(position - x) return total_distance # Example usage print(lost_cow(int(input()), int(input()))) ``` 该版本通过逐步调整步长和方向完成了整个搜索流程[^4]。 ---
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值