c++最长单词

输入一个字符串,将此字符串中最长的单词输出。要求至少使用一个自定义函数。

输入格式:

测试数据有多组,处理到文件尾。每组测试数据输入一个字符串(长度不超过80)。

输出格式:

对于每组测试,输出字符串中的最长单词,若有多个长度相等的最长单词,输出最早出现的那个。这里规定,单词只能由大小写英文字母构成。

输入样例:

Keywords insert, two way insertion sort,
Abstract This paper discusses three method for two way insertion
words. insert, two way sorted.

输出样例:

#include <iostream>
#include <cstring>
using namespace std;

//判断字符是不是英文字符
bool isEnglishChar(char c)
{
	if((c >= 'a' && c <= 'z' ) || (c >= 'A' && c <= 'Z'))
		return true;
	else return false;
}
//查找每个单词,返回最长的 
//算法:重复查找,如果英文字符不断增加1,否则如果遇到一个非英文字符,然后
//判断他是不是最长。 

void getLongestWord(char s[])
{
	int len = strlen(s);
	char longestWord[100], tempWord[100]; 
	int longestLen = 0, tempLen = 0;
	for(int i = 0 ; i <= len ; i ++) 
	{
		if(isEnglishChar(s[i])) //英文字符
		{
			tempWord[tempLen] = s[i];
			tempLen ++;
		}
		else //非英文字符
		{
			if(tempLen != 0)
			{
				if(tempLen > longestLen)
				{
					longestLen = tempLen;
					tempWord[tempLen] = '\0';
					//longestWord = tempWord;(错误)
					strcpy(longestWord, tempWord);
				}
				tempLen = 0;
			 } 
		}
	}
	cout << longestWord << endl;
} 

int main()
{
	char s[100];
	while(cin.getline(s, 100))
	{
		getLongestWord(s);
	}
	return 0;
}
insertion
discusses
insert
  • 1
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值