配置Diurd遇到的坑

IUD

这个要加上不然sql监控不到,要注意添加log4j的依赖,不然会报错

<dependency>
    <groupId>log4j</groupId>
    <artifactId>log4j</artifactId>
    <version>1.2.16</version>
    <scope>compile</scope>
</dependency>

tomcat在tomcat8.5.3、tomcat9中现在高版本不支持请求中带有"[]",报错

解决办法:

1.换到低版本的Tomcat

2.在Catalina.properties中添加

tomcat.util.http.parser.HttpParser.requestTargetAllow=|{}

这个东西明显是允许“|”和大括号的

3.添加

tomcat.util.buf.UDecoder.ALLOW_ENCODED_SLASH=true

以上方法我没有试过,是在网上查询的,大家遇到遇到这个问题可以试试

我是在application配置文件中加上

server.tomcat.relaxed-query-chars=[,]

亲测这个好使,把不能识别的特殊标识加入这个属性中

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页