输入一个正整数n,输出一个按以下规律变化的n行的直角三角形,每个数据都采用6个域宽左对齐的方式显示。
输入格式:
输入一个正整数。
输出格式:
输出按规律变化的图形,每个数据都采用6个域宽左对齐的方式显示。
输入样例:
3
输出样例:
1
2 4
3 6 9
代码如下:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
for(int i = 1; i <= n; i++) {
for(int j = 1; j <= i; j++)
System.out.printf("%-6d",i * j);
System.out.println("");
}
}
}