Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

#include<stdio.h>
int a[1000005];
int main()
{
    int A,B,n;
    a[0]=1;
    a[1]=1;
    while(scanf("%d %d %d",&A,&B,&n)!=EOF)
    {
        if(A==0&&B==0&&n==0)
            break;
        for(int i=2;i<49;i++)
        {
            a[i]=(A*a[i-1]%7+B*a[i-2]%7)%7;    
        }
        printf("%d\n",a[n%49-1]);
    }
    return 0;
} 

关于两次模7,每次有7种情况,49为周期,只能题目给出的测试数据,还有许多周期为6 16 24等的情况,49并不能作为其周期,还需要进行特殊情况输出,这种做法并不是正确解法,矩阵快速幂才可满足所有情况。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值