Borg Maze POJ - 3026 (BFS+最小生成树)

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8

11

说实话,一开始看不懂题,想不到是最小生成树,看了网上的题解,才发现是BFS+最小生成树,Kuangbin说是因为Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.)这句话才是最小生成树的理由,我没读懂。但是知道了是BFS+最小生成树就知道怎么写了。注意输入的时候存在坑点。

#include <algorithm>  
#include <iostream>   
#include <cstring>  
#include <iomanip>  
#include <string>  
#include <vector>  
#include <cstdio>  
#include <queue>  
#include <stack>  
#include <cmath>  
#include <map>  
#include <set>  
#define INF 0x3f3f3f3f
const  int Max = 1005;   
using namespace std;  
  
char arr[60][60];  
bool vis[60][60];  
struct node
{  
    int x,y,step;  
}cnt,ant;  
int Map[105][105],n,m,top;    //top是'A'和'S'点的个数和 
int dis[105],Pos[60][60];     
bool Vis[105];  
int d[4][2]={1,0,-1,0,0,1,0,-1};
  
void bfs(int x,int y)      //搜索找出所有字母之间的最短距离存在Map中 
{   
    memset(vis,false,sizeof(vis));  
    queue<node>q;  
    ant.x = x;
	ant.y = y;
	ant.step = 0;  
    vis[ant.x][ant.y] = true;  
    q.push(ant);  
    while(!q.empty()){  
        ant = q.front();
		q.pop();  
        if(arr[ant.x][ant.y] == 'A' || arr[ant.x][ant.y] == 'S')
		{  
            Map[Pos[x][y]][Pos[ant.x][ant.y]] = Map[Pos[ant.x][ant.y]][Pos[x][y]] = ant.step;  
        }  
        for(int i=0;i<4;i++){  
            int xx = ant.x + d[i][0];  
            int yy = ant.y + d[i][1];  
            if(xx >= 0 && xx < m && yy >= 0 && yy < n && arr[xx][yy]!='#' && !vis[xx][yy])
			{  
                vis[xx][yy] = true;  
                cnt.x = xx;
				cnt.y = yy;
				cnt.step = ant.step + 1;  
                q.push(cnt);  
            }  
        }  
    }  
}  
int Prim(int x)
{
    memset(Vis,false,sizeof(Vis));  
    for(int i=1;i<top;i++)  
    {
 		dis[i] = Map[1][i];       	
	} 
    int ans = 0;  
    Vis[x] = true;  
    for(int i=2;i<top;i++)
	{  
        int _min = INF,k = -1;  
        for(int j=1;j<top;j++)
		{  
            if(!Vis[j] && dis[j] < _min)
			{  
                _min = dis[j];  
                k = j;  
            }  
        }  
        ans += _min;  
        Vis[k] = true;  
        for(int j=1;j<top;j++)
		{  
            if(!Vis[j] && dis[j] > Map[k][j])
			{  
                dis[j] = Map[k][j];  
            }  
        }  
    }  
    return ans;  
}  
int main()
{  
	//freopen("C:/input.txt", "r", stdin);
    int T;  
    scanf("%d",&T);  
    while(T--)
	{  
        scanf("%d %d\n",&n,&m);  
        top = 1;  
        for(int i=0;i<m;i++)
		{  
            gets(arr[i]);  
            for(int j=0;j<n;j++)
			{  
                if(arr[i][j] == 'S' || arr[i][j] == 'A')
				{  
                    Pos[i][j] = top;  //标记点的坐标 
                    top += 1;  
                }  
            }  
        }  
        for(int i=0;i<=top;i++)  
            for(int j=0;j<=top;j++)  
                if(i == j)  
                    Map[i][j] = 0;  
                else  
                    Map[i][j] = INF;  
        for(int i=0;i<m;i++)
		{  
            for(int j=0;j<n;j++)
			{  
                if(arr[i][j] == 'S' || arr[i][j] == 'A')
				{  
                    bfs(i,j);  
                }  
            }  
        }  
        printf("%d\n",Prim(1));  
    }  
    return 0;  
}  

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值