The Accomodation of Students HDU - 2444 染色法判二分图+最大匹配

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other. 

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room. 

Calculate the maximum number of pairs that can be arranged into these double rooms. 

InputFor each data set: 
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs. 

Proceed to the end of file. 

OutputIf these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms. 
Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

Sample Output

No

3

看了好多博客,发现一种是bfs+染色法判二分图,一种是利用队列来判二分图,但是发现用队列来判容易超时,不知道为什么,既然bfs+染色法不超时,那就先学最好用的吧。因为是双向的,所以最后结果要除2。当时死在了输出No的时候,o要小写,还WA了好几次,我以为自己写错了。以后读题还是要仔细一点。

#include<iostream>
#include<stdio.h>
#include<cstring>

using namespace std;

const int maxn=205;
const int inf=0x3f3f3f3f;
int mp[maxn][maxn];
int vis[maxn],col[maxn];
int link[maxn];
int n,m,ans;
void init()
{
	memset(mp,0,sizeof(mp));
	memset(link,0,sizeof(link));
	memset(col,-1,sizeof(col));
	ans=0;
}
bool bfs(int u)
{
	int i;
	bool temp;
	for(i=1;i<=n;i++)
	{
		if(mp[u][i])
		{
			if(col[i]==-1)
			{
				col[i]=!col[u];
				temp=bfs(i);
				if(temp==0)
				{
					return false;
				}
			}
			else if(col[i]==col[u])
			{
				return false;
			}
		} 
	} 
	return true;
}
int find(int x)
{
	for(int i=1;i<=n;i++)
	{
		if(!vis[i]&&mp[x][i])
		{
			vis[i]=1;
			if(link[i]==0||find(link[i]))
			{
				link[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int match()
{
	for(int i=1;i<=n;i++)
	{
		memset(vis,0,sizeof(vis));
		if(find(i))
		{
			ans++;
		}
	}
	return 0;
}
int main()
{
	//freopen("C:/input.txt","r",stdin);
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    	if(n==1)
    	{
    		printf("No\n");
    		continue;
		}
    	init();
    	for(int i=0;i<m;i++)
    	{
    		int t1,t2;
    		scanf("%d%d",&t1,&t2);
    		mp[t1][t2]=mp[t2][t1]=1;
		}
		col[1]=1;
		if(bfs(1))
		{
			match();
			printf("%d\n",ans/2);
		}
		else
		{
			printf("No\n");
		}
	}
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值