poj 1724 ROADS (分层最短路)

http://poj.org/problem?id=1724

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 

  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100


Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

分层最短路   dij+堆优化 +dp思想

两种写法感觉是写的像是一种,因为思路不变,在dij那里改了改求的东西而已。

第一种

#pragma GCC optimize(2)

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 2e5 + 100;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int k, n, r, tot;
int head[maxn];
int dis[110][maxn];   //表示1到i花费为j的最短距离
struct node
{
	int u, v, cost, next, dis;
	
}edge[maxn];
struct qnode
{
	int dis, cost, num;
	bool operator <(const qnode &p) const
	{
		return dis > p.dis;
	}
	qnode(int _num, int _dis,int _cost) 
	{
		num = _num;
		dis = _dis;
		cost = _cost;
	}
};
void init()
{
	memset(head, -1, sizeof(head));
	tot = 0;
	return;
}
void addedge(int u, int v, int dis, int cost)
{
	edge[tot].u = u;
	edge[tot].v = v;
	edge[tot].dis = dis;
	edge[tot].cost = cost;
	edge[tot].next = head[u];
	head[u] = tot++;
}
int dij()
{
	priority_queue<qnode>pq;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 0; j <= k; j++)
		{
			dis[i][j] = inf;
		}
	}
	dis[1][0] = 0;
	pq.push(qnode(1, 0, 0));
	while (!pq.empty())
	{
		qnode e = pq.top();
		pq.pop();
		int u = e.num;
		int tmp_k = e.cost;
		if (u == n)
		{
			return e.dis;
		}
		for (int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].v;
			int cost = edge[i].cost + tmp_k;
			if (cost > k)
			{
				continue;
			}
			if (dis[v][cost] > e.dis + edge[i].dis)
			{
				dis[v][cost] = e.dis + edge[i].dis;
				pq.push(qnode(v, dis[v][cost], cost));
			}
		}
	}
	return -1;
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	scanf("%d%d%d", &k, &n, &r);
	init();
	for (int i = 1; i <= r; i++)
	{
		int a, b, c, d;
		scanf("%d%d%d%d", &a, &b, &c, &d);
		addedge(a, b, c, d);
	}
	printf("%d\n", dij());
	return 0;
}

第二种:

#pragma GCC optimize(2)

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 2e5 + 100;
const int inf = 0x3f3f3f3f;
typedef long long ll;
int k, n, r, tot;
int head[maxn];
int dis[110][maxn];   //表示1到i花费为j的最短距离
struct node
{
	int u, v, cost, next, dis;
	
}edge[maxn];
struct qnode
{
	int dis, cost, num;
	bool operator <(const qnode &p) const
	{
		return dis > p.dis;
	}
	qnode(int _num, int _dis,int _cost) 
	{
		num = _num;
		dis = _dis;
		cost = _cost;
	}
};
void init()
{
	memset(head, -1, sizeof(head));
	tot = 0;
	return;
}
void addedge(int u, int v, int dis, int cost)
{
	edge[tot].u = u;
	edge[tot].v = v;
	edge[tot].dis = dis;
	edge[tot].cost = cost;
	edge[tot].next = head[u];
	head[u] = tot++;
}
int dij()
{
	priority_queue<qnode>pq;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 0; j <= k; j++)
		{
			dis[i][j] = inf;
		}
	}
	dis[1][0] = 0;
	pq.push(qnode(1, 0, 0));
	while (!pq.empty())
	{
		qnode e = pq.top();
		pq.pop();
		int u = e.num;
		int tmp_k = e.cost;
		if (u == n)
		{
			return dis[u][tmp_k];
		}
		for (int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].v;
			int cost = edge[i].cost + tmp_k;
			if (cost > k)
			{
				continue;
			}
			if (dis[v][cost] > dis[u][tmp_k] + edge[i].dis)
			{
				dis[v][cost] = dis[u][tmp_k] + edge[i].dis;
				pq.push(qnode(v, dis[v][cost], cost));
			}
		}
	}
	return -1;
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	scanf("%d%d%d", &k, &n, &r);
	init();
	for (int i = 1; i <= r; i++)
	{
		int a, b, c, d;
		scanf("%d%d%d%d", &a, &b, &c, &d);
		addedge(a, b, c, d);
	}
	printf("%d\n", dij());
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值