poj 1050 To the Max (dp)

Language:Default

To the Max

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 52805 Accepted: 27923

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

 

给出一个N*N的矩阵,问最大子矩阵的值是多少。

做法就是压缩矩阵,压缩成一行来求。

#pragma GCC optimize(2)
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int maxn = 500;
const int inf = 0x3f3f3f3f;
typedef long long ll;

int m[maxn][maxn];

int main()
{
	//freopen("C://input.txt", "r", stdin);
	int n, max, i, j, k, tmp;

	while (scanf("%d", &n) != EOF)
	{
		max = -inf;
		/*
		输入时,顺便求出各行的最大字段和的最大值
		*/
		for (i = 0; i<n; ++i)
		{
			tmp = 0;
			for (j = 0; j<n; ++j)
			{
				scanf("%d", &m[i][j]);
				if (tmp > 0)
				{
					tmp += m[i][j];
				}
				else
				{
					tmp = m[i][j];
				}
				if (tmp > max)
				{
					max = tmp;
				}
			}
		}
		for (i = 0; i<n - 1; ++i)
		{
			for (j = i + 1; j<n; ++j)
			{
				tmp = 0;
				for (k = 0; k<n; ++k)
				{
					//相当于把子矩阵多行压缩为一行了
					m[i][k] += m[j][k];
					if (tmp > 0)
					{
						tmp += m[i][k];
					}
					else
					{
						tmp = m[i][k];
					}

					if (tmp > max)
					{
						max = tmp;
					}
				}
			}
		}
		printf("%d\n", max);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值