Eddy's research I
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 4570 Accepted Submission(s): 2736
Problem Description
Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .
Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
Output
You have to print a line in the output for each entry with the answer to the previous question.
Sample Input
11 9412
Sample Output
11 2*2*13*181
题目的意思:将一个数分为若干个素数相乘;
集体思路:因为1 <= x <= 65535 ; 先把1 - 65535 之间的素数筛选出来,再每一个查找;
代码:
#include <cstdio>
#include <iostream>
#include <cmath>
using namespace std;
int p[66000] , r = 1;
void prime()//筛选素数
{
int i , j;
p[0] = 2;
for(j = 3 ; j <= 65535 ; j+= 2)
{
int k = sqrt((double)j);
//注意sqrt(j) 在VC下没有运行错误,但交代码的时候会Competitor Error,所以sqrt((double) j);
for(i = 2; i <= k ; i++)
{
if(j % i ==0)
break;
}
p[r++] = j;
}
}
int main()
{
int x ;
int i;
prime();
while(cin >> x)
{
int k = x;
for(i = 0; i < r ;i ++)
{
while(x % p[i] == 0)//从第一个素数开始查找
{
x /= p[i];
cout << p[i];
if(x != 1)
cout << '*';
}
}
cout << endl;
}
return 0;
}