HDU 6092 Rikka with Subset(背包+思维)

Rikka with Subset


Problem Description 
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1−An and their sum is m. Then for each subset S of A, Yuta calculates the sum of S.

Now, Yuta has got 2n numbers between [0,m]. For each i∈[0,m], he counts the number of is he got as Bi.

Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An.

It is too difficult for Rikka. Can you help her?

Input 
The first line contains a number t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104).

The second line contains m+1 numbers B0−Bm(0≤Bi≤2n).

Output 
For each testcase, print a single line with n numbers A1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.

Sample Input 

2 3 
1 1 1 1 
3 3 
1 3 3 1

Sample Output 
1 2 
1 1 1 

Hint

In the first sample,  A  is  [1,2] A  has four subsets  [],[1],[2],[1,2]  and the sums of each subset are  0,1,2,3 . So  B=[1,1,1,1]  

Source
2017 Multi-University Training Contest - Team 5


题意:给出序列a的长度n,序列元素和为m,给出序列b,其中bi为序列a任意子集合sum为i的个数,输出字典序最小的序列a



题解:如果 B_iBi 是 BB 数组中除了 B_0B0 以外第一个值00 的位置,那么显然 ii 就是 AA 中的最小数。

现在需要求出删掉 ii 后的 BB 数组,过程大概是反向的背包,即从小到大让 B_j-=B_{j-i}Bj=Bji

时间复杂度 O(nm)O(nm)


#include<iostream>
#include<stdio.h>
#include<string.h>
#define ll long long
using namespace std;
int b[10005];
int a[55];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<=m;i++)
            scanf("%d",&b[i]);
        int coun=0;
        while(coun<n)
        {
            int i=1;
            for(i;i<=m;i++)
            {
                if(b[i]!=0)
                    break;
            }
            b[i]--;
            a[coun++]=i;
            for(int j=i+1;j<=m;j++)
                b[j]-=b[j-i];
        }
        for(int i=0;i<n;i++)
        {
            cout<<a[i];
            if(i==n-1) cout<<endl;
            else cout<<" ";
        }
    }
    return  0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值