紫薯---第三章 J - Periodic Strings

A character string is said to have period
k
if it can be formed by concatenating one or more repetitions
of another string of length
k
. For example, the string ”
abcabcabcabc
” has period 3, since it is formed
by 4 repetitions of the string ”
abc
”. It also has periods 6 (two repetitions of ”
abcabc
”) and 12 (one
repetition of ”
abcabcabcabc
”).
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer
N
indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up
to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are
separated by a blank line.
Sample Input
1
HoHoHo
Sample Output
2


解析
就最近自己的情况而言,有好几次就是因为超时,没A出题来!!!教训啊,真真儿的体现出方法的重要性!所以,要学会用简单的方法,而不是仅仅学会了暴力就万无一失了!


代码实现:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    int n = 0;
    char m[100];
    scanf("%d", &n);
    while (n--)
    {
       int i, j;
        scanf("%s", m);
        int len = strlen(m);
        for (i = 1; i <= len; ++i)
        {
            if (len % i == 0)
            {
                int f = 1;
                for (j = i; j < len; ++j)
                {
                    if (m[j]!=m[j%i])
                    {
                        f = 0;
                        break;
                    }
                }
                if (f==1)
                {
                    printf("%d\n", i);
                    break;
                }
            }
        }
        if (n!=0)
            printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值