离散题目17

离散题目17
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

给出集合X和X上的关系R,求关系R在X上的对称闭包s(R)。

例如:

X={1,2,3,4,5} , R={<1,1>,<2,1>,<3,3>,<2,3>,<3,2>,<4,5>}

s(R)= {<1,1>,<1,2>,<2,1>,<2,3>,<3,2>,<3,3>,<4,5>,<5,4>}
Input

多组输入,每组输入第一行为集合X的元素;第二行为一个整数n ( n > 0 ),代表X上的关系R中序偶的个数;接下来n行用来描述X上的关系R,每行两个数字,表示关系R中的一个序偶。细节参考示例输入。

非空集合X的元素个数不大于500,每个元素的绝对值不大于2^32 - 1。
Output

每组输入对应一行输出,为X上关系R的对称闭包s(R),s(R)中的序偶根据序偶中的第一个值升序排列,如果第一个值相同则根据第二个值升序排列;具体输出格式见样例(注意:样例每个逗号后有一个空格)。
Example Input

1 2 3 4 5
6
1 1
2 1
3 3
2 3
3 2
4 5

Example Output

[(1, 1), (1, 2), (2, 1), (2, 3), (3, 2), (3, 2), (3, 3), (4, 5), (5, 4)]

Hint
Author

#include <bits/stdc++.h>
using namespace std;
struct node
{
   int x;
   int y;
   int num;
}T[121211];
int cmp(const void * a, const void * b)
{
  struct node * c = (struct node *)a;
  struct node * d = (struct node *)b;
  if(c->x!=d->x)
  return (c->x-d->x);
  if(c->y!=d->y)
  return (c->y-d->y);
  return (c->num-d->num);
}
set<int> a;
int main()
{
    string ss, buf;
    int t, x, y, n;
    while(getline(cin, ss))
    {
        int top = 0;
        stringstream cs(ss);
        while(cs>>buf)
        {
          sscanf(buf.c_str(), "%d", &t);
          a.insert(t);
        }
        cin>>n;
        for(int i=0;i<n;i++)
        {
         cin>>x>>y;
         if(a.count(x)&&a.count(y))
         {
            T[top].x = x;
            T[top].y = y;
            T[top].num = top;
            top++;
         if(T[top-1].x!=T[top-1].y)
         {
            T[top].x = T[top-1].y;
            T[top].y = T[top-1].x;
            T[top].num = top;
            top++;
         }
         }
        }
        qsort(&T[0], top, sizeof(T[0]), cmp);
        if(top>0)
        {
           cout<<"[("<<T[0].x<<", "<<T[0].y<<")";
           for(int i=1;i<top;i++)
           {
            printf(", (%d, %d)", T[i].x, T[i].y);
           }
           cout<<"]"<<endl;
        }
        a.clear();
        getline(cin, ss, '\n');
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值