A - Wireless Network

[A - Wireless Network]

(https://cn.vjudge.net/contest/163007#problem/A)
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS

总结:
今天真的是特别的郁闷,一直卡题,一天做了两道题,我真的是醉了……之前的一道题,我觉得自己就是太心急了,做题沉不下心,毛毛躁躁的,代码改的很乱,最后又要重敲,特别浪费时间。
回归题目,这道题目是并查集的题,修复电脑,然后输出询问是否可以通信。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 1212
int book[MAXN];
struct node
{
    int x;//横坐标
    int y;//纵坐标
    int pre;//父节点
}t[MAXN];
int d;
int find(int a)//寻找父节点
{
    while(a!=t[a].pre)
        a = t[a].pre;
    return a;
}
void merge(struct node a, struct node b)//合并
{
    int root1 = find(a.pre);
    int root2 = find(b.pre);
    if(root1!=root2)
        if((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)<=d*d)//注意,只有两台电脑的距离小于等于要求的距离,才可以合并
        t[root1].pre = root2;
}
int main()
{
    int n,a, b;
    scanf("%d %d", &n, &d);
    memset(book, 0, sizeof(book));
    for(int i=1;i<=n;i++)//初始化
        t[i].pre = i;
    for(int i=1;i<=n;i++)
        scanf("%d %d", &t[i].x, &t[i].y);
    char c;
    while(scanf("\n%c", &c)!=EOF)
    {
        if(c=='O')//判断,修复
        {
            scanf("%d", &a);
            book[a] = 1;
            for(int i=1;i<=n;i++)//看看有哪些节点可以合并
            {
                if(book[i]==1&&i!=a)
                    merge(t[i],t[a]);
            }
        }
        else
        {
            scanf("%d %d", &a, &b);
            if(find(a)==find(b))
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值