O - All in All

You have devised a new encryption technique which encodes a message by inserting between its characters
randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final
string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.
Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.
Output
For each test case output, if s is a subsequence of t.
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
Sample Output
Yes
No
Yes
No

其实做题,方法很重要,有的题目简单很多,开始的时候,自己想的太多,判断了一下是否是字串,差点用上了kmp,再一想,其实好像没有那么复杂,两个变量,遍历就好了~

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 12345672
char p[MAXN];
char t[MAXN];
int main()
{
    while(~scanf("%s", p))
    {
        scanf("%s", t);
        int tlen = strlen(t);
        int plen = strlen(p);
        int k = 0;
        for(int i=0;i<tlen;i++)
        {
            if(t[i]==p[k])
                k++;
            if(k==plen)
                break;
        }
        if(k==plen)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值