D - Find The Multiple(dfs)

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

这道题目刷新了我的观念,连样例都过不了的代码,也可以AC~
(因为这道题目的意思是,输入一个数,然后输出只含有0和1的数字,并且是输入的数的倍数,当然,随意一个都可以~)

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
int flag;
int n;
void dfs(unsigned __int64 a, int n, int k)//long long 都存不了~,64位整型
{
    if(flag)//如果找到了,返回
        return;
    if(a%n==0)//看看是否可以被n整除
    {
        printf("%I64u\n", a);
        flag = 1;//标记
        return ;
    }
    if(k==19)
        return ;//不能超过19位
    //两条路径,每次寻找到的时候,增加一位数字,要么为0,要么为1
    dfs(a*10, n, k+1);//增加0
    dfs(a*10+1, n, k+1);//增加1
}
int main()
{
    while(~scanf("%d", &n)&&n)
    {
        flag = 0;
        dfs(1, n, 0);//搜索
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值