Connect the Cities(Prim)

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20964 Accepted Submission(s): 5007

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output
1

最小生成树,不过要注意别超时~

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define INF 0x3f3f3f3f
int ma[1211][1211];
int v[1211];
int dist[1211];
void Prim(int n)//最小生成树
{
    memset(v, 0, sizeof(v));
    for(int i=1;i<=n;i++)//初始化
        dist[i] = ma[1][i];
    v[1] = 1;
    int ans = 0;//记录费用
    int flag = 0;
    for(int i=2;i<=n;i++)
    {
        int point = 1;
        int min = INF;
        for(int j=1;j<=n;j++)
        {
            if(v[j]==0&&dist[j]<min)
            {
                min = dist[j];
                point = j;
            }
        }
        if(point==1)//如果没有被更新,则此图不连通,标记,跳出
        {
            flag = 1;
            break;
        }
        v[point] = 1;
        ans += min;
        for(int j=1;j<=n;j++)//更新剩下的节点的值
        {
            if(ma[point][j]<dist[j]&&v[j]==0)
                dist[j] = ma[point][j];
        }
    }
    if(!flag)//联通,输出费用
        printf("%d\n", ans);
    else//否则-1
        printf("-1\n");
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, m, k;
        scanf("%d %d %d", &n, &m, &k);
        for(int i=0;i<=n;i++)//初始化
        {
            for(int j=0;j<=n;j++)
            {
                if(i==j)
                    ma[i][j] = 0;
                else
                    ma[i][j] = INF;
            }
        }
        for(int i=0;i<m;i++)
        {
            int a, b, c;
            scanf("%d %d %d", &a, &b, &c);
            if(ma[a][b]>c)//注意,可能存在多条
                ma[a][b] = ma[b][a] = c;
        }
        for(int i=0;i<k;i++)//将已经联通的路,费用清为0
        {
            int a, b, c;
            scanf("%d", &a);
            scanf("%d", &b);
           a--;
           while(a--)//每两个点之间都要更新
           {
               scanf("%d", &c);
               ma[b][c] = ma[c][b] = 0;
               b = c;
           }
        }
        Prim(n);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值