数据结构实验之排序四:寻找大富翁
Time Limit: 200MS Memory Limit: 512KB
Submit Statistic
Problem Description
2015胡润全球财富榜调查显示,个人资产在1000万以上的高净值人群达到200万人,假设给出N个人的个人资产值,请你快速找出排前M位的大富翁。
Input
首先输入两个正整数N( N ≤ 10^6)和M(M ≤ 10),其中N为总人数,M为需要找出的大富翁数目,接下来给出N个人的个人资产,以万元为单位,个人资产数字为正整数,数字间以空格分隔。
Output
一行数据,按降序输出资产排前M位的大富翁的个人资产值,数字间以空格分隔,行末不得有多余空格。
Example Input
6 3
12 6 56 23 188 60
Example Output
188 60 56
Hint
请用堆排序完成。
Author
xam
发现有的时候,快排也就不一定好用~虽然这题快排也可以做,但还是get一下新知识吧!
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int a[12];
void heapadjust(int i, int length)//对于堆得调整
{
int t = a[i];//记录堆顶元素
int j = i * 2 + 1;
while(j<length)
{
if(j+1<length&&a[j]>a[j+1])//找到两个节点的最小值
j++;
if(a[j]<a[i])//更新父节点
{
a[i] = a[j];
i = j;
j = i * 2 + 1;
}
else
break;
}
a[i] = t;//更新
}
void makeminheap(int length)//建立小堆
{
for(int i=(length-1)/2;i>=0;i--)
heapadjust(i, length);
}
void heapsort(int length)//排序
{
makeminheap(length);
for(int i=length-1;i>=1;i--)
{
int temp = a[0];
a[0] = a[i];
a[i] = temp;
heapadjust(0, i);
}
}
int main()
{
int n, m;
scanf("%d %d", &n, &m);
for(int i=0;i<m;i++)
scanf("%d", &a[i]);
makeminheap(m);//首先建立一个最小堆
for(int i=m;i<n;i++)
{
int k;
scanf("%d", &k);
if(k>a[0])
{
a[0] = k;
makeminheap(m);//不断更新
}
}
heapsort(m);//排序
for(int i=0;i<m;i++)
printf("%d%c", a[i], i==m-1?'\n':' ');
return 0;
}