D - Mayor's posters (线段树+离散化)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,… , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

给出一段区间,贴海报,海报之间可能覆盖,问最后可以看到的海报的数量是多少。
这道题目由于给出的数量很大,不方便用数组来做,就可以选择使用离散化。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
int li[1234567], ri[1234567], x[1234567], book[1234567], ans;
int cover[1234567*4];
void pushdown(int node)//向下更新
{
   if(cover[node]!=-1)
   {
     cover[node*2] = cover[node * 2 + 1] = cover[node];
     cover[node] = -1;
   }
}
void updata(int l, int r, int c, int left, int right, int node)//区间更新
{
   if(l<=left&&right<=r)
   {
      cover[node] = c;
      return ;
   }
   pushdown(node);
   int m = (left + right) / 2;
   if(l<=m)
   updata(l, r, c, left, m, node * 2);
   if(r>m)
   updata(l, r, c, m+1, right, node * 2 + 1);
}
int find(int key, int k)//寻找某个值的位置
{
    int l = 0, r = k, m;
    while(l<=r)
    {
       m = (l + r) / 2;
       if(x[m]==key)
       return m;
       if(x[m]<key)
       l = m + 1;
       else
       r = m;
    }
    return -1;
}
void Query(int l, int r, int node)//求出有多少的海报在外面
{
    if(cover[node]!=-1)
    {
       if(book[cover[node]]==-1)
       ans++;
       book[cover[node]] = 1;
       return ;
    }
    if(l==r)
    return ;
    int m = (l + r) / 2;
    Query(l, m, node * 2);
    Query(m+1, r, node * 2 + 1);
}
int main()
{
   int t, n;
    scanf("%d", &t);
    while(t--)
    {
       int num = 0;
       scanf("%d", &n);
       for(int i=0;i<n;i++)
       {
          scanf("%d %d", &li[i], &ri[i]);
          x[num++] = li[i];
          x[num++] = ri[i];
       }
       //去重
       sort(x, x+num);
       int k = 1;
       for(int i=1;i<num;i++)
       {
         if(x[i]!=x[i-1])
         x[k++] = x[i];
       }
       for(int i=k-1;i>0;i--)
       {
          if(x[i]!=x[i-1]+1)
          x[k++] = x[i-1] + 1;
       }
       sort(x, x+k);
       memset(cover, -1, sizeof(cover));
       for(int i=0;i<n;i++)
       {
          int l = find(li[i], k), r = find(ri[i], k);
          updata(l, r, i, 0, k, 1);
       }
       ans = 0;
       memset(book, -1, sizeof(book));
       Query(0, k, 1);
       printf("%d\n", ans);
    }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值